Технология Fast Ethernet (IEEE 802.3u)

Технология Fast Ethernet является эволюционным развитием классической технологии Ethernet. Ее основными достоинствами являются:

  • увеличение пропускной способности сегментов сети до 100 Мб/c;
  • сохранение метода случайного доступа Ethernet;
  • сохранение звездообразной топологии сетей и поддержка традиционных сред передачи данных - витой пары и оптоволоконного кабеля.
Указанные свойства позволяют осуществлять постепенный переход от сетей 10Base-T - наиболее популярного на сегодняшний день варианта Ethernet - к скоростным сетям, сохраняющим значительную преемственность с хорошо знакомой технологией: Fast Ethernet не тре бует коренного переобучения персонала и замены оборудования во всех узлах сети. Официальный стандарт 100Base-T (802.3u) установил три различных спецификации для физического уровня (в терминах семиуровневой модели OSI) для поддержки следующих типов кабельных систем:
  • 100Base-TX для двухпарного кабеля на неэкранированной витой паре UTP Category 5, или экранированной витой паре STP Type 1;
  • 100Base-T4 для четырехпарного кабеля на неэкранированной витой паре UTP Category 3, 4 или 5;
  • 100Base-FX для многомодового оптоволоконного кабеля.

Fast Ethernet как развитие классического Ethernet'а

Рост требований к пропускной способности локальных сетей

Сегодня все чаще и чаще возникают повышенные требование к пропускной способности каналов между клиентами сети и серверами. Это происходит по разным причинам:

  • повышение производительности клиентских компьютеров;
  • увеличение числа пользователей в сети;
  • появление приложений, работающих с мультимедийной информацией, которая хранится в файлах очень больших размеров;
  • увеличение числа сервисов, работающих в реальном масштабе времени.

Следовательно, имеется потребность в экономичном решении, предоставляющем нужную пропускную способность во всех перечисленных случаях. Ситуация усложняется еще и тем, что нужны различные технологические решения - для организации магистралей сети и подключ ения серверов одни, а для подключения настольных клиентов - другие.

10-Мегабитный Ethernet устраивал большинство пользователей на протяжении около 15 лет. Однако в начале 90-х годов начала ощущаться его недостаточная пропускная способность. Если для компьютеров на процессорах Intel 80286 или 80386 с шинами ISA (8 Мбайт/с) или EISA (32 Мбайт/с) пропускная способность сегмента Ethernet составляла 1/8 или 1/32 канала "память - диск", то это хорошо согласовывалась с соотношением объемов локальных данных и внешних данных для компьютера. Теперь же у мощных клиентских станций с процессорами Pentium или Pentium PRO и шиной PCI (133 Мбайт/с) эта доля упала до 1/133, что явно недостаточно. Поэтому многие сегменты 10-Мегабитного Ethernet'а стали перегруженными, реакция серверов в них значительно упала, а частота возникнове ния коллизий существенно возросла, еще более снижая номинальную пропускную способность.

Способы повышения пропускной способности сети

Для повышения пропускной способности сети можно применить несколько способов: сегментация сети с помощью мостов и маршрутизаторов, сегментация сети с помощью коммутаторов и повышение пропускной способности самого протокола.

Сегментация сети с помощью мостов или маршрутизаторов может повысить пропускную способность сегментов сети за счет их разгрузки от трафика других сегментов только в том случае, когда межсегментный трафик составляет незначительную долю от внутрисегментного , поскольку и мосты, и маршрутизаторы не обладают высокой внутренней пропускной способностью.

В начале 90-х годов произошло два значительных события, которые дали возможность повысить пропускную способность сегментов локальных сетей, и в первую очередь сегментов технологии Ethernet.

Первое событие состояло в появлении мостов нового поколения - коммутаторов, которые в отличие от традиционного моста имели большое количество портов и обеспечивали передачу кадров между портами одновременно. Это позволило теперь эффективно применять комму таторы и для тех сетей, в которых межсегментный трафик не очень отличался от внутрисегментного. Будущее технологии Ethernet после появления коммутаторов стало более устойчивым, так как появилась возможность соединить низкую стоимость технологии Ethernet с высокой производительностью сетей, построенных на основе коммутаторов.

Второе событие заключалось в появлении экспериментальных сетей, в которых использовался протокол Ethernet с более высокой битовой скоростью передачи данных, а именно 100 Мб/с. До этого только технология Fiber Distributed Data Interface (FDDI) обесп ечивала такую битовую скорость, но она была специально разработана для построения магистралей сетей и была слишком дорогой для подключения к сети отдельных рабочих станций или серверов.

Создание стандарта Fast Ethernet

В 1992 году группа производителей сетевого оборудования, включая таких лидеров технологии Ethernet как SynOptics, 3Com и ряд других, образовали некоммерческое объединение Fast Ethernet Alliance для разработки стандарта на новую технологию, котора обобщила бы достижения отдельных компаний в области Ethernet-преемственного высокоскоростного стандарта. Новая технология получила название Fast Ethernet.

Одновременно были начаты работы в институте IEEE по стандартизации новой технологии - там была сформирована исследовательская группа для изучения технического потенциала высокоскоростных технологий. За период с конца 1992 года и по конец 1993 года группа IEEE изучила 100-Мегабитные решения, предложенные различными производителями. Наряду с предложениями Fast Ethernet Alliance группа рассмотрела также и другую высокоскоростную технологию, предложенную компаниями Hewlett-Packard и AT&T.

В центре дискуссий была проблема сохранения соревновательного метода доступа CSMA/CD. Предложение по Fast Ethernet'у сохраняло этот метод и тем самым обеспечивало преемственность и согласованность сетей 10Base-T и 100Base-T. Коалиция HP и AT&T, котора я имела поддержку гораздо меньшего числа производителей в сетевой индустрии, чем Fast Ethernet Alliance, предложила совершенно новый метод доступа, называемый Demand Priority. Он существенно менял картину поведения узлов в сети, поэтому не смог впи саться в технологию Ethernet и стандарт 802.3, и для его стандартизации был организован новый комитет IEEE 802.12.

В мае 1995 года комитет IEEE принял спецификацию Fast Ethernet в качестве стандарта 802.3u, который не является самостоятельным стандартом, а представляет собой дополнение к существующему стандарту 802.3 в виде глав с 21 по 30. Отличия Fast Ethernet от Et hernet сосредоточены на физическом уровне (рисунок 1.1).

Рис. 1.1. Отличия стека протоколов 100Base-T от стека протоколов 10Base-T

Более сложная структура физического уровня технологии Fast Ethernet вызвана тем, что в ней используется три варианта кабельных систем - оптоволокно, 2-х парная витая пара категории 5 и 4-х парная витая пара категории 3, причем по сравнению с вариантами фи зической реализации Ethernet (а их насчитывается шесть), здесь отличия каждого варианта от других глубже - меняется и количество проводников, и методы кодирования. А так как физические варианты Fast Ethernet создавались одновременно, а не эволюционно, как для сетей Ethernet, то имелась возможность детально определить те подуровни физического уровня, которые не изменяются от варианта к варианту, и остальные подуровни, специфические для каждого варианта.

Метод доступа к среде CSMA/CD

Подуровни LLC и MAC в стандарте Fast Ethernet не претерпели изменений. Напомним кратко их функции.

Подуровень Logical Link Control (LLC)

Подуровень LLC обеспечивает интерфейс протокола Ethernet с протоколами вышележащих уровней, например, с IP или IPX. Кадр LLC, изображенный на рисунке 1.2, вкладывается в кадр MAC, и позволяет за счет полей DSAP и SSAP идентифицировать адрес сервисов назна чения и источника соответственно. Например, при вложении в кадр LLC пакета IPX, значения как DSAP, так и SSAP должны быть равны Е0. Поле управления кадра LLC позволяет реализовать процедуры обмена данными трех типов.

  • Процедура типа 1 определяет обмен данными без предварительного установления соединения и без повторной передачи кадров в случае обнаружения ошибочной ситуации, то есть является процедурой дейтаграммного типа. Именно этот тип процедуры и используется в о всех практических реализациях Ethernet. Поле управления для этого типа процедур имеет значение 03, что определяет все кадры как ненумерованные.
  • Процедура типа 2 определяет режим обмена с установлением соединений, нумерацией кадров, управлением потоком кадров и повторной передачей ошибочных кадров. В этом режиме протокол LLC аналогичен протоколу HDLC. В локальных сетях Ethernet этот режим испо льзуется редко.
  • Процедура типа 3 определяет режим передачи данных без установления соединения, но с получением подтверждения о доставке информационного кадра адресату. Только после этого может быть отправлен следующий информационный кадр.

Рис. 1.2. Формат кадра LLC с расширением SNAP

Существует расширение формата кадра LLC, называемое SNAP (Subnetwork Access Protocol). В случае использования расширения SNAP в поля DSAP и SSAP записывается значение AA, тип кадра по-прежнему равен 03, а для обозначения типа протокола, вложенного в поле данных, используются следующие 4 байта, причем байты идентификатора организации (OUI) всегда равны 00 (за исключением протокола AppleTalk), а последний байт (TYPE) содержит идентификатор типа протокола (например, 0800 для IP).

Заголовки LLC или LLC/SNAP используются мостами и коммутаторами для трансляции протоколов канального уровня по стандарту IEEE 802.2H.

Подуровень управления доступом к среде Media Access Control (MAC)

Подуровень MAC ответственен за формирование кадра Ethernet, получение доступа к разделяемой среде передачи данных и за отправку с помощью физического уровня кадра по физической среде узлу назначения.

Разделяемая среда Ethernet, независимо от ее физической реализации (коаксиальный кабель, витая пара или оптоволокно с повторителями), в любой момент времени находится в одном из трех состояний - свободна, занята, коллизия. Состояние занятости соответствуе т нормальной передаче кадра одним из узлов сети. Состояние коллизии возникает при одновременной передаче кадров более, чем одним узлом сети.

MAC-подуровень каждого узла сети получает от физического уровня информацию о состоянии разделяемой среды. Если она свободна, и у MAC-подуровня имеется кадр для передачи, то он передает его через физический уровень в сеть. Физический уровень одновременно с побитной передачей кадра следит за состоянием среды. Если за время передачи кадра коллизия не возникла, то кадр считается переданным. Если же за это время коллизия была зафиксирована, то передача кадра прекращается, и в сеть выдается специальная последов ательность из 32 бит (так называемая jam-последовательность), которая должна помочь однозначно распознать коллизию всеми узлами сети.

После фиксации коллизии MAC-подуровень делает случайную паузу, а затем вновь пытается передать данный кадр. Случайный характер паузы уменьшает вероятность одновременной попытки захвата разделяемой среды несколькими узлами при следующей попытке. Интервал, из которого выбирается случайная величина паузы, возрастает с каждой попыткой (до 10-ой), так что при большой загрузке сети и частом возникновении коллизий происходит притормаживание узлов. Максимальное число попыток передачи одного кадра - 16, после чего MAC-подуровень оставляет данный кадр и начинает передачу следующего кадра, поступившего с LLC-подуровня.

MAC-подуровень узла приемника, который получает биты кадра от своего физического уровня, проверяет поле адреса кадра, и если адрес совпадает с его собственным, то он копирует кадр в свой буфер. Затем он проверяет, не содержит ли кадр специфические ошибки: по контрольной сумме (FCS error), по максимально допустимому размеру кадра (jabber error), по минимально допустимому размеру кадра (runts), по неверно найденным границам байт (alignment error). Если кадр корректен, то его поле данных передается на LLC-по дуровень, если нет - то отбрасывается.

Форматы кадров

Форматы кадров технологии Fast Ethernet не отличаются от форматов кадров технологий 10-Мегабитного Ethernet'a. На рисунке 1.3 приведен формат MAC-кадра Ethernet, а также временные параметры его передачи по сети для скорости 10 Мб/с и для скорости 100 Мб/с .

Рис. 1.3. Формат MAC-кадра и времена его передачи

В кадрах стандарта Ethernet-II (или Ethernet DIX), опубликованного компаниями Xerox, Intel и Digital еще до появления стандарта IEEE 802.3, вместо двухбайтового поля L (длина поля данных) используется двухбайтовое поле T (тип кадра). Значение поля типа ка дра всегда больше 1518 байт, что позволяет легко различить эти два разных формата кадров Ethernet DIX и IEEE 802.3.

Все времена передачи кадров Fast Ethernet в 10 раз меньше соответствующих времен технологии 10-Мегабитного Ethernet'а: битовый интервал составляет 10 нс вместо 100 нс, а межкадровый интервал - 0.96 мкс вместо 9.6 мкс соответственно.

Спецификации физического уровня

Структура физического уровня и его связь с MAC-подуровнем

Для технологии Fast Ethernet разработаны различные варианты физического уровня, отличающиеся не только типом кабеля и электрическими параметрами импульсов, как это сделано в технологии 10 Мб/с Ethernet, но и способом кодирования сигналов и количеством исп ользуемых в кабеле проводников. Поэтому физический уровень Fast Ethernet имеет более сложную структуру, чем классический Ethernet. Эта структура представлена на рисунке 1.4.

Рис. 1.4. Структура физического уровня Fast Ethernet

Физический уровень состоит из трех подуровней:

  • Уровень согласования (reconciliation sublayer);
  • Независимый от среды интерфейс (Media Independent Interface, MII);
  • Устройство физического уровня (Physical layer device, PHY).

Устройство физического уровня (PHY) обеспечивает кодирование данных, поступающих от MAC-подуровня для передачи их по кабелю определенного типа, синхронизацию передаваемых по кабелю данных, а также прием и декодирование данных в узле-приемнике.

Интерфейс MII поддерживает независимый от используемой физической среды способ обмена данными между MAC-подуровнем и подуровнем PHY. Этот интерфейс аналогичен по назначению интерфейсу AUI классического Ethernet'а за исключением того, что интерфейс AUI рас полагался между подуровнем физического кодирования сигнала (для любых вариантов кабеля использовался одинаковый метод физического кодирования - манчестерский код) и подуровнем физического присоединения к среде, а интерфейс MII располагается между MAC-поду ровнем и подуровнями кодирования сигнала, которых в стандарте Fast Ethernet три - FX, TX и T4.

Подуровень согласования нужен для того, чтобы согласовать работу подуровня MAC с интерфейсом MII.

Интерфейс MII

Существует два варианта реализации интерфеса MII: внутренний и внешний.

При внутреннем варианте микросхема, реализующая подуровни MAC и согласования, с помощью интерфеса MII соединяется с микросхемой трансивера внутри одного и того же конструктива, например, платы сетевого адаптера или модуля маршрутизатора (рисунок 1.5). Мик росхема трансивера реализует все функции устройства PHY.

Рис. 1.5. Сетевой адаптер с внутренним интерфейсом MII

Внешний вариант соответствует случаю, когда трансивер вынесен в отдельное устройство и соединен кабелем MII через разъем MII с микросхемой MAC-подуровня (рисунок 1.6). Разъем MII в отличие от разъема AUI имеет 40 контактов, максимальная длина кабеля MII с оставляет 1 метр. Сигналы, передаваемые по интерфейсу MII, имеют амплитуду 5 В.

Рис. 1.6. Использование внешнего трансивера с интерфейсом MII

Интерфейс MII может использоваться не только для связи PHY с MAC, но и для соединения устройств PHY с микросхемой повторения сигналов в многопортовом повторителе-концентраторе (рисунок 1.7).

Рис. 1.7. Повторитель со встроенными устройствами PHY

Передача данных через MII

MII использует 4-битные порции данных для параллельной передачи их между MAC и PHY. Канал передачи данных от MAC к PHY образован 4-битной шиной данных, которая синхронизируется тактовым сигналом, генерируемым PHY, а также сигналом "Пере-
дача", генерируемым MAC-подуровнем.

Аналогично, канал передачи данных от PHY к MAC образован другой 4-битной шиной данных, которая синхронизируется тактовым сигналом и сигналом "Прием", которые генерируются PHY.

Сообщения об ошибках в MII

Если устройство PHY обнаружило ошибку в состоянии физической среды, то оно может передать сообщение об этом на подуровень MAC в виде сигнала "Ошибка приема" (receive error). MAC-подуровень (или повторитель) сообщают об ошибке устройству PHY с по мощью сигнала "Ошибка передачи" (transmit error). Обычно, повторитель, получив от PHY какого-либо порта сигнал "Ошибка приема", передает на все устройства PHY остальных портов сигнал "Ошибка передачи".

Управление конфигурацией в MII

В MII определена двухпроводная шина для обмена между MAC и PHY управляющей информацией. MAC-подуровень использует эту шину для передачи PHY данных о режиме его работы. PHY передает по этой шине информацию по запросу о статусе порта и линии. Данные о конфи гурации, а также о состоянии порта и линии хранятся соответственно в двух регистрах: регистре управления (Control Register) и регистре статуса (Status Register).

Регистр управления используется для установки скорости работы порта, для указания, будет ли порт принимать участие в процессе автопереговоров о скорости линии, для задания режима работы порта - полудуплексный или полнодуплексный, и т.п. Функция авт опереговоров (Auto-negotiation) позволяет двум устройствам, соединенным одной линией связи, автоматически, без вмешательства оператора, выбрать наиболее высокоскоростной режим работы, который будет поддерживается обоими устройствами.

Регистр статуса содержит информацию о действительном текущем режиме работы порта, в том числе и в том случае, когда режим выбран в результате проведения автопереговоров.

Регистр статуса может содержать данные об одном из следующих режимов:

  • 100Base-T4;
  • 100Base-TX full-duplex;
  • 100Base-TX half-duplex;
  • 10 Mb/s full-duplex;
  • 10Mb/s half-duplex;
  • Ошибка на дальнем конце линии.

Физический уровень 100Base-FX - многомодовое оптоволокно

Физический уровень PHY ответственен за прием данных в параллельной форме от MAC-подуровня, трансляцию их в один (TX или FX) или три последовательных потока бит с возможностью побитной синхронизации и передачу их через разъем на кабель. Аналогично, на прие мном узле уровень PHY должен принимать сигналы по кабелю, определять моменты синхронизации бит, извлекать биты из физических сигналов, преобразовывать их в параллельную форму и передавать подуровню MAC.

Структура физического уровня 100Base-FX представлена на рисунке 1.8.

Рис. 1.8. Физический уровень PHY FX

Эта спецификация определяет работу протокола Fast Ethernet по многомодовому оптоволокну в полудуплексном и полнодуплексном режимах на основе хорошо проверенной схемы кодирования и передачи оптических сигналов, использующейся уже на протяжении ряда лет в с тандарте FDDI. Как и в стандарте FDDI, каждый узел соединяется с сетью двумя оптическими волокнами, идущими от приемника (Rx) и от передатчика (Tx).

Между спецификациями PHY FX и PHY TX есть много общего, поэтому общие для двух спецификаций свойства будут даваться под обобщенным названием PHY FX/TX.

Метод кодирования 4B/5B

10 Мб/с версии Ethernet используют манчестерское кодирование для представления данных при передаче по кабелю. Метод кодирования 4B/5B определен в стандарте FDDI, и он без изменений перенесен в спецификацию PHY FX/TX. При этом методе каждые 4 бита данных M AC-подуровня (называемых символами) представляются 5 битами. Использование избыточного бита позволяет применить потенциальные коды при представлении каждого из пяти бит в виде электрических или оптических импульсов. Потенциальные коды обладают по сравнени ю с манчестерскими кодами более узкой полосой спектра сигнала, а, следовательно, предъявляют меньшие требования к полосе пропускания кабеля. Однако, прямое использование потенциальных кодов для передачи исходных данных без избыточного бита невозможно из-з а плохой самосинхронизации приемника и источника данных: при передаче длинной последовательности единиц или нулей в течение долгого времени сигнал не изменяется, и приемник не может определить момент чтения очередного бита.

При использовании пяти бит для кодирования шестнадцати исходных 4-х битовых комбинаций, можно построить такую таблицу кодирования, в которой любой исходный 4-х битовый код представляется 5-ти битовым кодом с чередующимися нулями и единицами. Тем самым обе спечивается синхронизация приемника с передатчиком. Так как исходные биты MAC-подуровня должны передаваться со скоростью 100Мб/c, то наличие одного избыточного бита вынуждает передавать биты результирующего кода 4B/5B со скоростью 125 Мб/c, то есть межбит овое расстояние в устройстве PHY составляет 8 наносекунд.

Так как из 32 возможных комбинаций 5-битовых порций для кодирования порций исходных данных нужно только 16, то остальные 16 комбинаций в коде 4В/5B используются в служебных целях.

Наличие служебных символов позволило использовать в спецификациях FX/TX схему непрерывного обмена сигналами между передатчиком и приемником и при свободном состоянии среды, что отличает их от спецификации 10Base-T, когда незанятое состояние среды обознача ется полным отсутствием на ней импульсов информации. Для обозначения незанятого состояния среды используется служебный символ Idle (11111), который постоянно циркулирует между передатчиком и приемником, поддерживая их синхронизм и в периодах между передач ами информации, а также позволяя контролировать физическое состояние линии (рисунок 1.9).

Рис. 1.9. Обмен символами Idle при незанятом состоянии среды

Существование запрещенных комбинаций символов позволяет отбраковывать ошибочные символы, что повышает устойчивость работы сетей с PHY FX/TX.

Для отделения кадра Ethernet от символов Idle используется комбинация символов Start Delimiter (пара символов JK), а после завершения кадра перед первым символом Idle вставляется символ T (рисунок 1.10).

Рис. 1.10. Непрерывный поток данных спецификаций PHY FX/TX

Передача 5-битовых кодов по линии методом NRZI

После преобразования 4-битовых порций MAC-кодов в 5-битовые порции PHY их необходимо представить в виде оптических или электрических сигналов в кабеле, соединяющем узлы сети. Спецификации PHY FX и PHY TX используют для этого различные методы физического к одирования - NRZI и MLT-3 соответственно. Эти же методы определены в стандарте FDDI для передачи сигналов по оптоволокну (спецификация PMD) и витой паре (спецификация TP-PMD).

Рассмотрим метод NRZI - Non Return to Zero Invert to ones - метод без возврата к нулю с инвертированием для единиц. Этот метод представляет собой модификацию простого потенциального метода кодирования, называемого Non Return to Zero (NRZ), к огда для представления 1 и 0 используются потенциалы двух уровней. В методе NRZI также используется два уровня потенциала сигнала, но потенциал, используемый для кодирования текущего бита зависит от потенциала, который использовался для кодирования предыд ущего бита (так называемое дифференциальное кодирование). Если текущий бит имеет значение 1, то текущий потенциал представляет собой инверсию потенциала предыдущего бита, независимо от его значения. Если же текущий бит имеет значение 0, то текущий потенци ал повторяет предыдущий.

Из описания метода NRZI видно, что для обеспечения частых изменений сигнала, а значит и для поддержания самосинхронизации приемника, нужно исключить из кодов слишком длинные последовательности нулей. Коды 4B/5B построены так, что гарантируют не более трех нулей подряд при любом сочетании бит в исходной информации. На рисунке 1.11 приведен пример кодирования последовательности бит методами NRZ и NRZI.

Рис. 1.11. Сравнение методов кодирования NRZ и NRZI

Основное преимущество NRZI кодирования по сравнению с NRZ кодированием в более надежном распознавании передаваемых 1 и 0 на линии в условиях помех.

Физический уровень 100Base-TХ - двухпарная витая пара

Структура физического уровня спецификации PHY TX представлена на рисунке 1.12.

Рис. 1.12. Структура физического уровня PHY TX

Основные отличия от спецификации PHY FX - использование метода MLT-3 для передачи сигналов 5-битовых порций кода 4В/5B по витой паре, а также наличие функции автопереговоров (Auto-negotiation) для выбора режима работы порта.

Метод MLT-3 использует потенциальные сигналы двух полярностей для представления 5-битовых порций информации (рисунок 1.13).

Рис. 1.13. Метод кодирования MLT-3

Кроме использования метода MLT-3, спецификация PHY TX отличается от спецификации PHY FX тем, что в ней используется пара шифратор-дешифратор (scrambler/de-
scrambler), как это определено в спецификации ANSI TP-PMD. Шифратор принимает 5-битовые порции данных от подуровня PCS, выполняющего кодирование 4B/5B, и зашифровывает сигналы перед передачей на подуровень MLT-3 таким образом, чтобы равномерно распределит ь энергию сигнала по всему частотному спектру - это уменьшает электромагнитное излучение кабеля.

Auto-negotiation - автопереговоры по принятию режима работы порта

Спецификации PHY TX и PHY T4 поддерживают функцию Auto-negotiation, с помощью которой два взаимодействующих устройства PHY могут автоматически выбрать наиболее эффективный режим работы.

Описанная ниже схема Auto-negotiation является теперь стандартом технологии 100Base-T. До этого производители применяли различные собственные схемы автоматического определения скорости работы взаимодействующих портов, которые не были совместимы. Принятую в качестве стандарта схему Auto-negotiation предложила первоначально компания National Semiconductor под названием NWay.

Всего в настоящее время определено 5 различных режимов работы, которые могут поддерживать устройства PHY TX или PHY T4 на витых парах:

10Base-T ( 2 пары категории 3

10Base-T full-duplex ( 2 пары категории 3

100Base-TX ( 2 пары категории 5 (или Type 1A STP)

100Base-TX full-duplex ( 2 пары категории 5 (или Type 1A STP)

100Base-T4 ( 4 пары категории 3

Режим 10Base-T имеет самый низкий приоритет при переговорном процессе, а режим 100Base-T4 - самый высокий. Переговорный процесс происходит при включении питания устройства, а также может быть инициирован и в любой момент модулем управления.

Для организации переговорного процесса используются служебные сигналы проверки целостности линии технологии 10Base-T - link test pulses, если узел-партнер поддерживает только стандарт 10Base-T. Узлы, поддерживающие функцию Auto-negotiation, также использу ют существующую технологию сигналов проверки целостности линии, при этом они посылают пачки таких импульсов, инкапсулирующие информацию переговорного процесса Auto-negotiation. Такие пачки носят название Fast Link Pulse burst (FLP).

Устройство, начавшее процесс auto-negotiation, посылает своему партнеру пачку импульсов FLP, в котором содержится 8-битное слово, кодирующее предлагаемый режим взаимодействия, начиная с самого приоритетного, поддерживаемого данным узлом.

Если узел-партнер поддерживает функцию Auto-negotuiation и также может поддерживать предложенный режим, то он отвечает пачкой импульсов FLP, в которой подтверждает данный режим и на этом переговоры заканчиваются. Если же узел-партнер может поддерживать ме нее приоритетный режим, то он указывает его в ответе и этот режим выбирается в качестве рабочего. Таким образом, всегда выбирается наиболее приоритетный общий режим узлов.

Узел, который поддерживает только технологию 10Base-T, каждые 16 миллисекунд посылает импульсы для проверки целостности линии, связывающей его с соседним узлом. Такой узел не понимает запрос FLP, который делает ему узел с функцией Auto-negotiation, и прод олжает посылать свои импульсы. Узел, получивший в ответ на запрос FLP только импульсы проверки целостности линии, понимает, что его партнер может работать только по стандарту 10Base-T и устанавливает этот режим работы и для себя.

Полнодуплексный режим работы

Узлы, поддерживающие спецификации PHY FX и PHY TX, могут работать в полнодуплексном режиме (full-duplex mode). В этом режиме не используется метод доступа к среде CSMA/CD и отсутствует понятие коллизий - каждый узел одновременно передает и принимает кадры данных по каналам Tx и Rx.

Полнодуплексная работа возможна только при соединения сетевого адаптера с коммутатором или же при непосредственном соединении коммутаторов.

При полнодуплексной работе стандарты 100Base-TX и 100Base-FX обеспечивают скорость обмена данными между узлами 200 Мб/с.

Полнодуплексный режим работы для сетей 100Base-T пока не принят комитетом IEEE в качестве стандарта. Тем не менее многие производители выпускают как сетевые адаптеры, так и коммутаторы для этого режима. Из-за отсутствия стандарта эти продукты не обязатель но корректно работают друг с другом.

В полнодуплексном режиме необходимо определить процедуры управления потоком кадров, так как без этого механизма возможны ситуации, когда буферы коммутатора переполнятся и он начнет терять кадры Ethernet, что всегда крайне нежелательно, так как восстановле ние информации будет осуществляться более медленными протоколами транспортного или прикладного уровней.

Ввиду отсутствия стандартов на полнодуплексные варианты Ethernet'a каждый производитель сам определяет способы управления потоком кадров в коммутаторах и сетевых адаптерах. Обычно, при заполнении буфера устройства до определенного предела, это устройство посылает передающему устройству сообщение о временном прекращении передачи (XOFF). При освобождении буфера посылается сообщение о возможности возобновить передачу (XON).

Физический уровень 100Base-T4 - четырехпарная витая пара

Спецификация PHY T4 была разработана для того, чтобы можно было использовать для высокоскоростного Ethernet'а имеющуюся проводку на витой паре категории 3. Эта спецификация использует все 4 пары кабеля для того, чтобы можно было повысить общую пропускную способность за счет одновременной передачи потоков бит по нескольким витым парам.

Структура физического уровня PHY T4 изображена на рисунке 1.14.

Рис. 1.14. Физический уровень PHY T4

Вместо кодирования 4B/5В в этом методе используется кодирование 8B/6T. Каждые 8 бит информации MAC-уровня кодируются 6-ю троичными цифрами (ternary symbols), то есть цифрами, имеющими три состояния. Каждая троичная цифра имеет длительность 40 наносекунд. Группа из 6-ти троичных цифр затем передается на одну из трех передающих витых пар, независимо и последовательно. Четвертая пара всегда используется для прослушивания несущей частоты в целях обнаружения коллизии. Скорость передачи данных по каждой из трех передающих пар равна 33.3 Мб/c, поэтому общая скорость протокола 100Base-T4 составляет 100 Мб/c. В то же время из-за принятого способа кодирования скорость изменения сигнала на каждой паре равна всего 25 Мбод, что и позволяет использовать витую пару кате гории 3.

На рисунке 1.15 показано соединение порта MDI сетевого адаптера 100Base-T4 с портом MDI-X повторителя. Из рисунка видно, пара 1-2 всегда используется для передачи данных от порта MDI к порту MDI-X, пара 3-6 всегда используется для приема данных портом MDI от порта MDI-X, а пары 4-5 и 7-8 являются двунаправленными и используются и для приема, и для передачи, в зависимости от потребности.

Рис. 1.15. Соединение узлов по спецификации PHY T4

Правила построения сегментов Fast Ethernet при использовании повторителей класса I и класса II

Технология Fast Ethernet, как и все некоаксиальные варианты Ethernet'а рассчитана на подключение конечных узлов - компьютеров с соответствующими сетевыми адаптерами - к многопортовым концентраторам-повторителям или коммутаторам.

Правила корректного построения сегментов сетей Fast Ethernet включают:

  • ограничения на максимальные длины сегментов, соединяющих DTE c DTE;
  • ограничения на максимальные длины сегментов, соединяющих DTE с портом повторителя;
  • ограничения на максимальный диаметр сети;
  • ограничения на максимальное число повторителей и максимальную длину сегмента, соединяющего повторители.

Ограничения длин сегментов DTE-DTE

В качестве DTE (Data Terminal Equipment) может выступать любой источник кадров данных для сети: сетевой адаптер, порт моста, порт маршрутизатора, модуль управления сетью и другие подобные устройства. Порт повторителя не является DTE. В типичной кон фигурации сети Fast Ethernet несколько DTE подключается к портам повторителя, образуя сеть звездообразной топологии.

Спецификация IEEE 802.3u определяет следующие максимальные значения сегментов DTE-DTE:
Стандарт | Тип кабеля | Максимальная длина сегмента
100Base-TX | Category 5 UTP | 100 метров
100Base-FX | многомодовое оптоволокно 62.5/125 мкм | 412 метров (полудуплекс) 2 км (полный дуплекс)
100Base-T4 | Category 3,4 или 5 UTP | 100 метров

Ограничения, связанные с соединениями с повторителями

Повторители Fast Ethernet делятся на два класса.

Повторители класса I поддерживают все типы систем кодирования физического уровня: 100Base-TX/FX и 100Base-T4. Повторители класса II поддерживают только один тип системы кодирования физического уровня - 100Base-TX/FX или 100Base-T4.

В одном домене коллизий допускается наличие только одного повторителя класса I. Это связано с тем, что такой повторитель вносит большую задержку при распространении сигналов из-за необходимости трансляции различных систем сигнализации.

Максимальное число повторителей класса II в домене коллизий - 2, причем они должны быть соединены между собой кабелем не длиннее 5 метров.

Небольшое количество повторителей Fast Ethernet не является серьезным препятствием при построении сетей. Во-первых, наличие стековых повторителей снимает проблемы ограниченного числа портов - все каскадируемые повторители представляют собой один повторите ль с достаточным числом портов - до нескольких сотен. Во-вторых, применение коммутаторов и маршрутизаторов делит сеть на несколько доменов коллизий, в каждом из которых обычно имеется не очень большое число станций.

В следующей таблице сведены правила построения сети на основе повторителе класса I.
Тип кабелей | Максимальный диаметр сети | Максимальная длина сегмента
Только витая пара (TX) | 200 м | 100 м
Только оптоволокно (FX) | 272 м | 136 м
Несколько сегментов на витой паре и один на оптоволокне | 260 м | 100 м (TX) 160 м (FX)
Несколько сегментов на витой паре и несколько сегментов на оптоволокне | 272 м | 100 м (TX) 136 м (FX)

Эти ограничения проиллюстрированы типовыми конфигурациями сетей, показанными на рисунке 1.16.

Рис. 1.16. Примеры построения сети с помощью повторителей класса I

Управление в сетях Fast Ethernet. Параметры протокола Ethernet, отслеживаемые агентами SNMP и RMON

В отношении сетевого управления протокол Fast Ethernet ничем не отличается от классического 10-Мегабитного Ethernet'a. Для сбора информации о состоянии коммуникационных устройств, поддерживающих Fast Ethernet, и управления этими устройствами по сети испол ьзуется протокол SNMP и агенты, встроенные в устройства, либо выполненные в виде автономных зондов.

Агенты большинства производителей поддерживают в настоящее время как классическую для сетей TCP/IP базу управляющей информации MIB II (RFC-1213), так и базу RMON MIB, специально ориентированную на протоколы нижнего уровня Ethernet и Token Ring.

База MIB II ориентирована в основном на сбор статистики о протоколах сетевого и транспортного уровней стека TCP/IP, а протоколам физического и канального уровней, таким как Ethernet (и, соответственно Fast Ethernet) в ней уделяется не так много внимания.

Из многочисленных объектов, определенных в MIB II, работу коммуникационного устройства (повторителя, моста, коммутатора, маршрутизатора, сетевого адаптера) по протоколу Ethernet отражают в основном объекты группы Interfaces. Эти объекты описывают каждый п орт устройства в параметрах протокола канального уровня, то есть уровня Ethernet.

В число объектов, описывающих каждый конкретный интерфейс устройства, включены следующие:

ifType - тип протокола, который поддерживает интерфейс.

Этот объект принимает значения всех стандартных протоколов канального уровня, например, rfc877-x25, ethernet-csmacd, iso88023-csmacd, iso88024-tokenBus, iso88025-tokenRing, и т.д.

ifMtu - максимальный размер пакета сетевого уровня, который можно послать через этот интерфейс.

ifSpeed - пропускная способность интерфейса в битах в секунду (100 для Fast Ethernet).

ifPhysAddress - физический адрес порта, для Fast Ethernet им будет MAC-адрес.

ifAdminStatus - желаемый статус порта:

up - готов передавать пакеты ready to pass packets;

down - не готов передавать пакеты;

testing - находится в некотором тестовом режиме.

ifOperStatus - фактический текущий статус порта, имеет те же значения, что и ifAdminStatus.

ifInOctets - общее количество байт, принятое данным портом, включая служебные, с момента последней инициализации SNMP-агента.

ifInUcastPkts - количество пакетов с индивидуальным адресом интерфейса, доставленных протоколу верхнего уровня.

ifInNUcastPkts - количество пакетов с широковещательным или мультивещательным адресом интерфейса, доставленных протоколу верхнего уровня.

ifInDiscards - количество пакетов, которые были приняты интерфейсом, оказались корректными, но не были доставлены протоколу верхнего уровня, скорее всего из-за переполнения буфера пакетов или же по иной причине.

ifInErrors - количество пришедших пакетов, которые не были переданы протоколу верхнего уровня из-за обнаружения в них ошибок.

Кроме объектов, описывающих статистику по входным пакетам, имеются аналогичные объекты, но относящиеся к выходным пакетам.

Как видно из описания объектов MIB-II, эта база данных не дает детальной статистики по характерным ошибкам кадров Ethernet, кроме этого она не отражает изменение характеристик во времени.

Все эти возможности и многие другие полезные свойства реализованы в стандарте RMON MIB, описанном в RFC-1757.

Стандарт RMON MIB описывает 9 групп объектов:

  • Statistics - текущие накопленные статистические данные о характеристиках пакетов, количестве коллизий и т.п.
  • History - статистические данные, сохраненные через определенные промежутки времени для последующего анализа тенденций их изменений.
  • Alarms - пороговые значения статистических показателей, при превышении которых агент RMON генерирует определенное событие. Реализация этой группы требует реализации группы Events - события.
  • Host - данные о хостах сети, обнаруженных в результате анализа MAC-адресов кадров, циркулирующих в сети.
  • Host TopN - таблица N хостов сети, имеющих наивысшие значения заданных статистических параметров.
  • Traffic Matrix - статистика о интенсивности трафика между каждой парой хостов сети, упорядоченная в виде матрицы.
  • Filter - условия фильтрации пакетов; пакеты, удовлетворяющие заданному условию, могут быть либо захвачены, либо могут генерировать события.
  • Packet Capture - группа пакетов, захваченных по заданным условиям фильтрации.
  • Event - условия регистрации событий и оповещения о событиях.

Рассмотрим более подробно группу Statistics, которая определяет, какую информацию о кадрах (называемых в стандарте пакетами) Ethernet может предоставить агент RMON. Группа History основана на объектах группы Statistics, так как ее объекты просто позволяют строить временные ряды для объектов группы Statistics.

В группу Statistics входят наряду с некоторыми другими следующие объекты:

etherStatsDropEvents - общее число событий, при которых пакеты были проигнорированы агентом из-за недостатка его ресурсов. Сами пакеты при этом не обязательно были потеряны интерфейсом.

etherStatsOctets - общее число байт (включая ошибочные пакеты), принятые из сети (исключая преамбулу, н включая байты контрольной суммы).

etherStatsPkts - общее число полученных пакетов (включая ошибочные).

etherStatsBroadcastPkts - общее число хороших пакетов, которые были посланы по широковещательному адресу.

etherStatsMulticastPkts - общее число хороших пакетов, полученных по мультивещательному адресу.

etherStatsCRCAlignErrors - общее число полученных пакетов, которые имели длину (исключая преамбулу) между 64 и 1518 байтами, не содержали целое число байт (alignment error) или имели неверную контрольную сумму (FCS error).

etherStatsUndersizePkts - общее число пакетов, которые имели длину, меньше, чем 64 байта, но были правильно сформированы.

etherStatsOversizePkts - общее число полученных пакетов, которые имели длину больше, чем 1518 байт, но были тем не менее правильно сформированы.

etherStatsFragments - общее число полученных пакетов, которые не состояли из целого числа байт или имели неверную контрольную сумму, и имели к тому же длину, меньшую, чем 64 байта.

etherStatsJabbers - общее число полученных пакетов, которые не состояли из целого числа байт или имели неверную контрольную сумму, и имели к тому же длину, большую, чем 1518 байт.

etherStatsCollisions - наилучшая оценка числа коллизий на данном сегменте Ethernet.

etherStatsPkts64Octets - общее количество полученных пакетов (включая и плохие), размером в 64 байта.

etherStatsPkts65to127Octets - общее количество полученных пакетов (включая и плохие), размером от 65 до 127 байт.

etherStatsPkts128to255Octets - общее количество полученных пакетов (включая и плохие), размером от 128 до 255 байт.

etherStatsPkts256to511Octets - общее количество полученных пакетов (включая и плохие), размером от 256 до 511 байт.

etherStatsPkts512to1023Octets - общее количество полученных пакетов (включая и плохие), размером от 512 до 1023 байт.

etherStatsPkts1024to1518Octets - общее количество полученных пакетов (включая и плохие), размером от 1024 до 1518 байт.

Как видно из описания объектов, с помощью агента RMON, встроенного в повторитель или другое коммуникационное устройство, можно провести очень детальный анализ работы сегмента Ethernet или Fast Ethernet. Сначала можно получить данные о встречающихся в сегм енте типах ошибок в кадрах, а затем целесообразно собрать с помощью группы History зависимости интенсивности этих ошибок от времени (в том числе и привязав их ко времени). После анализа временных зависимостей часто уже можно сделать некоторые предваритель ные выводы об источнике ошибочных кадров, и на этом основании сформулировать более тонкие условия захвата кадров со специфическими признаками (задав условия в группе Filter), соответствующими выдвинутой версии. После этого можно провести еще более детальн ый анализ за счет изучения захваченных кадров, извлекая их из объектов группы Packet Capture.

В каких случаях рекомендуется использовать Fast Ethernet

У технологии Fast Ethernet есть несколько ключевых свойств, которые определяют области и ситуации ее эффективного применения. К этим свойствам относятся:

  • Большая степень преемственности по отношению к классическому 10-Мегабитному Ethernet'у;
  • Высокая скорость передачи данных - 100 Mб/c;
  • Возможность работать на всех основных типах современной кабельной проводки - UTP Category 5, UTP Category 3, STP Type 1, многомодовом оптоволокне.

Наличие многих общих черт у технологий Fast Ethernet и Ethernet дает простую общую рекомендацию - Fast Ethernet следует применять в тех организациях и в тех частях сетей, где до этого широко применялся 10-Мегабитный Ethernet, но сегодняшние условия или же ближайшие перспективы требуют в этих частях сетей более высокой пропускной способности. При этом сохраняется весь опыт обслуживающего персонала, привыкшего к особенностям и типичным неисправностям сетей Ethernet. Кроме того, можно по-преж-
нему использовать средства анализа протоколов, работающие с агентами MIB-II, RMON MIB и привычными форматами кадров.

Организаций, широко применяющих Ethernet весьма много, так как Ethernet был и остается наиболее эффективной технологией по отношению цена/производительность среди низкоскоростных (4 - 20 Мб/с) технологий. Это свойство относится теперь и к Fast Ethernet, н о применительно к технологиям со скоростью 100 Мб/c. Однако, Fast Ethernet кроме положительных свойств, унаследовал и недостатки технологии Ethernet - большие задержки доступа к среде при коэффициенте использования среды выше 30-40%, являющиеся следствием применения алгоритма доступа CSMA/CD, небольшие расстояния между узлами даже при использования оптоволокна - следствие метода обнаружения коллизий, отсутствие определения резервных связей в стандарте и отсутствие поддержки приоритетного трафика приложени й реального времени.

Fast Ethernet в сетях рабочих групп

К моменту появления стандарта Fast Ethernet в построении локальных сетей масштаба здания или кампуса сложился следующий подход - магистраль крупной сети строилась на технологии FDDI - высокоскоростной и отказоустойчивой, но весьма дорогой, а сети рабочих групп и отделов использовали Ethernet или Token Ring.

Поэтому основная область использования Fast Ethernet сегодня - это настольные применения, сети рабочих групп и отделов. При этом целесообразно совершать переход к Fast Ethernet постепенно, оставляя Ethernet там, где он хорошо справляется со своей работой. Одним из очевидных случаев, когда Ethernet не следует заменять Fast Ethernet'ом, является подключение к сети старых персональных компьютеров с шиной ISA - их пропускная способность канала "сеть - диск" не позволит пользователю ощутить выгоды от повышения в 10 раз скорости сетевой технологии. Для устранения узких мест для сетей, состоящих из таких компьютеров, больше подходит использование коммутаторов с портами 10 Мб/с, так как в этом случае узлам гарантированно предоставляется по 10 Мб/с - как раз столько, сколько им нужно при их архитектуре и параметрах производительности.

Новые клиентские компьютеры с процессором Pentium Pro и шиной PCI - очевидные претенденты на использование скорости 100 Мб/c. Поэтому даже при весьма неопределенных требованиях их пользователей к пропускной способности сети имеет смысл покупать для них се тевые адаптеры Fast Ethernet, которые могут работать на скорости 10 Мб/c, пока у организации не появятся концентраторы или коммутаторы с портами Fast Ethernet. Переход к скорости 100Мб/c будет для пользователей практически безболезненным, так как большинс тво сетевых адаптеров не нужно конфигурировать для перехода на Fast Ethernet (это не относится к полнодуплексному варианту Fast Ethernet, так как из-за отсутствия стандарта ручное конфигурирование может понадобиться).

Fast Ethernet в магистралях зданий и кампусов

Создание достаточно крупных сетей, к которым относятся сети зданий и кампусов с количеством узлов в несколько сотен, также возможно с использованием технологии Fast Ethernet. Эта технология может использоваться в таких сетях как в "чистом" виде, так и в сочетании с другими технологиями, например, FDDI или ATM.

Сети зданий и даже крупных этажей сейчас практически не строятся без использования коммутаторов, поэтому ограничения на максимальный диаметр сети в 250 - 272 метра легко преодолеваются, так как соединение коммутатор-коммутатор позволяет удлинить сеть до 4 12 м при полудуплексной связи на оптоволокне, и до 2 км при аналогичной полнодуплексной связи.

Отсутствие стандартного резервирования на уровне повторителей также мало ограничивает построение отказоустойчивых магистралей - поддержка коммутаторами алгоритма Spanning Tree позволяет автоматически переходить с основной отказавшей связи на резервную.

Основными двумя факторами, сдерживающими применение технологии Fast Ethernet на магистралях, являются:

  • широкое использование в настоящее время для этой цели технологии FDDI;
  • отсутствие у технологии Fast Ethernet средств поддержки трафика реального времени.

Поэтому, если эти факторы не относятся к вашей сети, то ее магистраль можно успешно строить и на коммутируемой технологии Fast Ethernet, особенно на ее полнодуплексной версии. Правда в последнем случае настоятельно рекомендуется использовать коммутаторы о дного и того же производителя.

Обзор оборудования, поддерживающего Fast Ethernet

Большая часть производителей коммуникационного оборудования для локальных сетей поддерживают технологию Fast Ethernet во всем спектре своих изделий - сетевых адаптерах, повторителях, коммутаторах и маршрутизаторах.

Наиболее распространенный тип физического интерфейса - 100Base-TX, а интерфейсы 100Base-T4 распространены в значительно меньшей степени. Интерфейсы 100Base-FX часто поддерживаются не непосредственно, а через интерфейс MII и соответствующий оптоволоконный трансивер.

Рассмотрим примеры некоторых продуктов компаний 3Com, Intel, Bay Networks и Cisco, поддерживающих технологию Fast Ethernet.

Сетевые адаптеры компании 3Com Fast EtherLink

Эти адаптеры выпускаются для шин PCI и EISA.

Адаптеры выполнены по технологии Parallel Tasking (как и серия EtherLink III) и работают на двух скоростях: 10 Мб/с и 100 Мб/с, обеспечивая высокую скорость передачи данных для стандартов 10Base-T и 100Base-T. Адаптеры сами распознают тип порта концентрат ора, к которому они подключены, поэтому при переходе с технологии 10Base-T на технологию 100Base-T нет необходимости производить изменения в аппаратуре или программах.

Адаптеры Fast EtherLink PCI и EISA поддерживают с помощью одного и того же выходного разъема как стандарт 100Base-TX, работающий по двум парам витых пар категории 5 (модель адаптера Fast EtherLink 10/100Base-TX), так и стандарт 100Base-T4, работающий по ч етырем парам проводов категорий 3,4 или 5 (модель адаптера Fast EtherLink 10/100Base-T4).

Адаптеры Fast EtherLink поддерживают стандарты управления SNMP и DMI (Desktop Management Interface).

Сетевой адаптер Intel EtherExpress PRO/100

Этот адаптер предназначен для работы по технологиям 10Base-T или 100Base-TX. Адаптер обладает свойством чувствительности к скорости порта, к которому он подключен, поэтому выбор скорости работы - 10 Мб/с или 100 Мб/с - происходит автоматически.

Адаптер имеет один порт RJ-45 и может работать с кабелем UTP Category 5 (2 пары) или 100 Ohm STP (2 пары).

Выпускаются варианты адаптера для шины EISA и шины PCI. Адаптер не имеет переключателей и не требует ручного конфигурирования перед установкой в компьютер.

Адаптер имеет низкий коэффициент использования ресурсов центрального процессора. На карте имеется буферная память размером в 16 КВ и контроллер Intel 82556.

Концентраторы SuperStack II Hub 100 компании 3Com

Эти концентраторы реализуют идеи каскадируемых концентраторов, реализованные компанией 3Com впервые для концентраторов LinkBuilder FMS II, для технологии Fast Ethernet.

Семейство SuperStack II Hub 100 наследует все преимущества концентраторов LinkBuilder FMS II - объединение до 8 концентраторов в стек, общую шину для всех концентраторов, SNMP/RMON управление от одного модуля управления на стек. В семейство входят концент раторы SuperStack II Hub 100 TХ и SuperStack II Hub 100 T4, первый появившийся на рынке концентратор, поддерживающий технологию Fast Ethernet на 4 витых парах категории 3.

Управление всей системой SuperStack осуществляется с помощью интегрированной системы управления сетями Transcend компании 3Com, работающей в средах наиболее популярных открытых платформ - UNIX, Windows, NMS и OS/2.

Концентраторы BayStack 100Base-T Hub компании Bay Networks

Концентратор BayStack 100Base-T Hub имеет 12 портов 100Base-TX с разъемами RJ-45. Концентратор имеет два слота расширения. Первый слот расширения может использоваться для установки либо модуля управления с поддержкой SNMP/RMON управления, либо для установ ки дополнительного интерфейсного модуля с 12 портами 100Base-TX. Второй слот расширения предназначен для установки адаптера 100Base-FX с разъемом SC.

В стек можно объединять до 6 концентраторов 100Base-T Hub, что для управляемого стека дает 132 порта FastEthernet.

Коммутаторы Fast Ethernet

Коммутаторы Fast Ethernet делятся на коммутаторы рабочих групп, имеющие большое количество низкоскоростных портов 10Base-T и один порт Fast Ethernet, и коммутаторы отделов и магистралей, поддерживающие коммутацию между несколькими портами Fast Ethernet.

Коммутатор LinkSwitch 1000 компании 3Com - один из лучших представителей коммутаторов для рабочих групп, отмеченный несколькими наградами как лучший продукт 1996 года. Он имеет 24 порта 10Base-T и один или два порта Fast Ethernet. Стоимость за один порт у этого коммутатора впервые в промышленности снизилась ниже отметки в $200 при высокой производительности. До 8 коммутаторов LinkSwitch 1000 могут собираться в стек.

Более сложные сети позволяет строить система Catalyst 3000 компании Cisco. Catalyst 3000 представляет собой оригинальную реализацию стековой архитектуры для коммутаторов. Эта архитектура поддерживается устройствами двух типов:

  • Коммутатор Catalyst 3000 c 16 портами 10Base-T, одним портом AUI и двумя слотами расширения. Модули расширения могут иметь либо 1 порт 100Base-TX, либо 3 порта 10Base-FL, либо 4 порта 10Base-T, либо 1 порт ATM. Порт мониторинга осуществляет зекрализац ию любого порта данных на внешний порт.
  • Catalyst Matrix - 8-ми портовая матрица коммутации, с помощью которой можно объединить в стек до 8 коммутаторов Catalyst 3000 для создания единого коммутирующего центра.

Коммутаторы Catalyst 3000 подключаются к Catalyst Matrix через специальные 280 Мб/с порты. Производительность шины Catalyst Matrix составляет 3.84 Гб/с.

Стек Catalyst 3000 поддерживает до 64 виртуальных сетей и позволяет фильтровать трафик по адресам источника и назначения. Максимальное число MAC-адресов - до 10000 на устройство.

Поддерживается алгоритм Spanning Tree и SNMP-управление.

Коммутатор LattisSwitch 28115 компании Bay Networks представляет собой коммутатор масштаба отдела или здания, так как он имеет 18 портов, каждый из которых может работать со скоростью 10 или 100 Мб/с. Поэтому данный коммутатор можно использовать не только для подключения отдельных быстродействующих серверов, но и для создания скоростной магистрали сети средних размеров.

Коммутатор имеет внутреннюю производительность 2 Гб/с, что достаточно для обслуживания всех его портов на максимальной скорости.

16 портов представляют собой порты RJ-45 для поддержки стандарта 100Base-TX, а два порта - фирменную реализацию интерфейса, близкого к MII, но отличающегося от него некоторыми особенностями. К этим портам можно подключать внешние трансиверы (FX или TX), в ыбирая нужную среду передачи данных - оптоволокно или витую пару. Эти два порта расширения можно использовать для скоростного соединения коммутаторов LattisSwitch между собой. При этом порты работают в полнодуплексном режиме и могут образовывать либо общи й канал передачи данных со скоростью 400Мб/с, либо использовать одну пару портов как резервную связь. При соединении коммутаторов друг с другом каналом 400 Мб/с образуется стек коммутаторов с общим количеством портов 487, причем скорость обмена данными ме жду портами не зависит от того, принадлежат они одному коммутатору или разным.

Интерфейсы Fast Ethernet в маршрутизаторах

Практически все модели модульных маршрутизаторов ведущих производителей имеют интерфейсные модули, поддерживающие Fast Ethernet. Это относится к маршрутизаторам Cisco 7500, 7000, маршрутизаторам Bay Networks ASN, BLN, BCN, маршрутизатору 3Com NETBuilder I I и многим другим.

Пример построения сети по технологии Fast Ethernet

В качестве примера построения сети с использованием технологии Fast Ethernet рассмотрим эскизный проект сети, предложенный компанией 3Com для сети масштаба кампуса в рамках мероприятия, названного High-Speed LAN Shoot-Out III. Это мероприятие состоялось в декабре 1995 года в Нью-Йорке, когда семи ведущим производителям коммуникационного оборудования для локальных сетей было предложено защитить одну из новых высокоскоростных технологий, разработав предложения по использованию своих продуктов для этой техно логии в одной из реальных сетей.

В состязании технологий приняли участие: 3Com, Madge Networks, Hewlett-Packard, FORE Systems, UB Networks, IBM и Bay Networks. Спонсорами мероприятия выступили журнал Data Communications и компания Rising Star Research. Организаторы соревнования разработа ли 4 предложения (RFP) по модернизации 4-х крупных корпоративных сетей, причем эти описания описывали реальные сети, работающие в различных организациях.

Компания 3Com разработала предложения по использованию технологии Fast Ethernet (естественно, реализованной в продуктах 3Com) для сети университетского кампуса. Сеть состояла из большого количества пользователей Ethernet, разделенных на большое количество рабочих групп. Кампус включал 180 зданий, из которых около 100 были многоэтажными. В качестве магистрали сети использовалось кольцо FDDI, объединяющее около 300 рабочих групп и около 23000 компьютеров. Загрузка сетей рабочих групп составляла в среднем 30 % с пиками в 65%. Загрузка магистрали составляла 45%, что достаточно много для FDDI, хотя FDDI может использоваться почти до 100% своей номинальной пропускной способности. Наибольшую нагрузку на сеть создавали передачи файлов. В будущем предполагается усл ожнение нагрузки за счет добавления приложений реального времени, использующих передачу голоса и видеоинформации.

Особенностью этой сети, усложняющей переход на высокоскоростные технологии, является кабельная система - основная ее часть внутри зданий выполнена на кабеле категории 3.

Решение, предложенное 3Com, представлено на рисунке 1.17. Основная особенность предложенного проекта - выбор тех частей сети, где 3Com предполагает перейти на технологию Fast Ethernet. Это в первую очередь сети зданий, а имеющуюся магистраль FDDI предпола гается сохранить на начальных этапах модернизации сети, запланировав переход на ATM только в будущем.

На уровне сетей рабочих групп 3Сом предлагает использовать три варианта модернизации.

Для рабочих групп, состоящих из мощных рабочих станций и сервера предлагается полный переход на разделяемую среду с технологией 100Base-T4 за счет использования адаптеров Fast EtherLink 10/100Base-T4 и стека повторителей SuperStack II Hub 100 T4. К стеку подключаются как рабочие станции, так и сервер рабочей группы.

Для рабочих групп, работающих на старой технике - PC с процессорами 386 и 486 и такими же серверами, предлагается использовать коммутируемый 10-Мегабитный Ethernet. Для таких групп устанавливается стек коммутаторов LinkSwitch 1000, к 10-Мегабитным портам которого подключаются как рабочие станции, так и серверы данной рабочей группы. Если в этой рабочей группе используется мощный сервер, то он подключается к 100-Мегабитному порту коммутатора.

Рис. 1.17. Варианты модернизации сети университета на основе технологии Fast Ethernet

Третий вариант организации рабочей группы является комбинацией двух первых. В нем используется как коммутируемая 10-Мегабитная среда для рабочих станций, так и разделяемая 100-Мегабитная среда для производительных серверов этой рабочей группы.

Для создания магистрали здания 3Сом предлагает также использовать технологию Fast Ethernet, но в коммутируемом варианте. Все связи от рабочих групп подключаются к 100 Мегабитным портам коммутатора. В качестве такого коммутатора предлагается три типа комму таторов. Наиболее дешевое решение - коммутатор LinkSwitch 3000, который поддерживает только технологию Fast Ethernet, и имеет 8 портов TX или FX. Коммутатор CELLplex 7600 поддерживает до 64 портов Fast Ethernet и может иметь интерфейсный модуль с 4 портам и АТМ. Эти порты могут понадобиться в будущем, при переходе от магистрали FDDI к магистрали АТМ как в здании, так и в сети кампуса. И, наконец, многофункциональный коммутатор LANplex 6000, поддерживающий коммутацию Fast Ethernet и FDDI, может быть полезен в том случае, когда магистраль кампуса останется на технологии FDDI.

В случае использования коммутаторов LinkSwitch 3000 или CELLplex 7600 в центре сети здания, 3Сом предлагает использовать для подключения к магистрали FDDI кампуса маршрутизаторы NETBuilder II с интерфейсами Fast Ethernet и FDDI. Маршрутизатор осуществляет переход с Fast Ethernet на FDDI, а также изолирует сеть здания от проблем сетей других зданий типа широковещательного шторма.

В случае использования в центре сети здания коммутатора LANplex 6000 можно отказаться от использования маршрутизатора, так как LANplex 6000 может обеспечить трансляцию Fast Ethernet-FDDI, а также за счет поддержки функций маршрутизатора изолировать сети з даний друг от друга.

К центру коммутации данных здания подключены по интерфейсу Fast Ethernet и мощные серверы, общие для всех рабочих групп здания.

Развитие магистрали кампуса 3Сом видит следующим образом. Первый этап развития - переход от разделяемого всеми зданиями кольца FDDI к нескольким кольцам, коммутируемым с помощью LANplex 6000. Второй этап - переход на АТМ магистраль, построенную на коммута торах CELLplex 7000 фирмы 3Сом. Это решение должно обеспечить лучшую масштабируемость магистрали - за счет возможности использования связей между магистральными коммутаторами на скорости 622 Мб/c. Кроме того, технология АТМ стандартным способом обеспечива ет сочетание компьютерного и мультимедийного трафика на одной магистрали.

Оглавление | Следующая глава

Back Home E-mail

Copyright © CIT


Технология FDDI

История создания стандарта FDDI

Технология Fiber Distributed Data Interface - первая технология локальных сетей, которая использовала в качестве среды передачи данных оптоволоконный кабель.

Попытки применения света в качестве среды, несущей информацию, предпринимались давно - еще в 1880 году Александр Белл запатентовал устройство, которое передавало речь на расстояние до 200 метров с помощью зеркала, вибрировавшего синхронно со звуковыми вол нами и модулировавшего отраженный свет.

Работы по использованию света для передачи информации активизировались в 1960-е годы в связи с изобретением лазера, который мог обеспечить модуляцию света на очень высоких частотах, то есть создать широкополосный канал для передачи большого количества инф ормации с высокой скоростью. Примерно в то же время появились оптические волокна, которые могли передавать свет в кабельных системах, подобно тому как медные провода передают электрические сигналы в традиционных кабелях. Однако потери света в этих волокна х были слишком велики, чтобы они могли быть использованы как альтернатива медным жилам. Недорогие оптические волокна, обеспечивающие низкие потери мощности светового сигнала и широкую полосу пропускания (до нескольких ГГц) появились только в 1970-е годы. В начале 1980-х годов началось промышленная установка и эксплуатация оптоволоконных каналов связи для территориальных телекоммуникационных систем.

В 1980-е годы начались также работы по созданию стандартных технологий и устройств для использования оптоволокнных каналов в локальных сетях. Работы по обобщению опыта и разработке первого оптоволоконного стандарта для локальных сетей были сосредоточены в Американском Национальном Институте по Стандартизации - ANSI, в рамках созданного для этой цели комитета X3T9.5.

Начальные версии различных составляющих частей стандарта FDDI были разработаны комитетом Х3Т9.5 в 1986 - 1988 годах, и тогда же появилось первое оборудование - сетевые адаптеры, концентраторы, мосты и маршрутизаторы, поддерживающие этот стандарт.

В настоящее время большинство сетевых технологий поддерживают оптоволоконные кабели в качестве одного из вариантов физического уровня, но FDDI остается наиболее отработанной высокоскоростной технологией, стандарты на которую прошли проверку временем и уст оялись, так что оборудование различных производителей показывает хорошую степень совместимости.

Основы технологии FDDI

Технология FDDI во многом основывается на технологии Token Ring, развивая и совершенствуя ее основные идеи. Разработчики технологии FDDI ставили перед собой в качестве наиболее приоритетных следующие цели:

  • Повысить битовую скорость передачи данных до 100 Мб/с;
  • Повысить отказоустойчивость сети за счет стандартных процедур восстановления ее после отказов различного рода - повреждения кабеля, некорректной работы узла, концентратора, возникновения высокого уровня помех на линии и т.п.;
  • Максимально эффективно использовать потенциальную пропускную способность сети как для асинхронного, так и для синхронного трафиков.

Сеть FDDI строится на основе двух оптоволоконных колец, которые образуют основной и резервный пути передачи данных между узлами сети. Использование двух колец - это основной способ повышения отказоустойчивости в сети FDDI, и узлы, которые хотят им восполь зоваться, должны быть подключены к обоим кольцам. В нормальном режиме работы сети данные проходят через все узлы и все участки кабеля первичного (Primary) кольца, поэтому этот режим назван режимом Thru - "сквозным" или "транзитным&qu ot;. Вторичное кольцо (Secondary) в этом режиме не используется.

В случае какого-либо вида отказа, когда часть первичного кольца не может передавать данные (например, обрыв кабеля или отказ узла), первичное кольцо объединяется со вторичным (рисунок 2.1), образуя вновь единое кольцо. Этот режим работы сети называется Wrap, то есть "свертывание" или "сворачивание" колец. Операция свертывания производится силами концентраторов и/или сетевых адаптеров FDDI. Для упрощения этой процедуры данные по первичному кольцу всегда передаются против часовой стрелки, а по вторичному - по часовой. Поэтому при образовании общего кольца из двух колец передатчики станций по-прежнему остаются подключенными к приемникам соседних станций, что позволяет правильно передавать и принимать информацию соседними станциями.

В стандартах FDDI отводится много внимания различным процедурам, которые позволяют определить наличие отказа в сети, а затем произвести необходимую реконфигурацию. Сеть FDDI может полностью восстанавливать свою работоспособность в случае единичных отказов ее элементов. При множественных отказах сеть распадается на несколько не связанных сетей.

Рис. 2.1. Реконфигурация колец FDDI при отказе

Кольца в сетях FDDI рассматриваются как общая разделяемая среда передачи данных, поэтому для нее определен специальный метод доступа. Этот метод очень близок к методу доступа сетей Token Ring и также называется методом маркерного (или токенного) кольца - token ring (рисунок 2.2, а).

Станция может начать передачу своих собственных кадров данных только в том случае, если она получила от предыдущей станции специальный кадр - токен доступа (рисунок 2.2, б). После этого она может передавать свои кадры, если они у нее имеются, в течение вр емени, называемого временем удержания токена - Token Holding Time (THT). После истечения времени THT станция обязана завершить передачу своего очередного кадра и передать токен доступа следующей станции. Если же в момент принятия токена у станции н ет кадров для передачи по сети, то она немедленно транслирует токен следующей станции. В сети FDDI у каждой станции есть предшествующий сосед (upstream neighbor) и последующий сосед (downstream neighbor), определяемые ее физическими связями и направлением передачи информации.

Рис. 2.2. Обработка кадров станциями кольца FDDI

Каждая станция в сети постоянно принимает передаваемые ей предшествующим соседом кадры и анализирует их адрес назначения. Если адрес назначения не совпадает с ее собственным, то она транслирует кадр своему последующему соседу. Этот случай приведен на рису нке (рисунок 2.2, в). Нужно отметить, что, если станция захватила токен и передает свои собственные кадры, то на протяжении этого периода времени она не транслирует приходящие кадры, а удаляет их из сети.

Если же адрес кадра совпадает с адресом станции, то она копирует кадр в свой внутренний буфер, проверяет его корректность (в основном по контрольной сумме), передает его поле данных для последующей обработки протоколу лежащего выше над FDDI уровня (наприм ер, IP), а затем передает исходный кадр по сети последующей станции (рисунок 2.2, г). В передаваемом в сеть кадре станция назначения отмечает три признака: распознавания адреса, копирования кадра и отсутствия или наличия в нем ошибок.

После этого кадр продолжает путешествовать по сети, транслируясь каждым узлом. Станция, являющаяся источником кадра для сети, ответственна за то, чтобы удалить кадр из сети, после того, как он, совершив полный оборот, вновь дойдет до нее (рисунок 2.2, д). При этом исходная станция проверяет признаки кадра, дошел ли он до станции назначения и не был ли при этом поврежден. Процесс восстановления информационных кадров не входит в обязанности протокола FDDI, этим должны заниматься протоколы более высоких уров ней.

На рисунке 2.3 приведена структура протоколов технологии FDDI в сравнении с семиуровневой моделью OSI. FDDI определяет протокол физического уровня и протокол подуровня доступа к среде (MAC) канального уровня. Как и многие другие технологии локальных сетей , технология FDDI использует протокол 802.2 подуровня управления каналом данных (LLC), определенный в стандартах IEEE 802.2 и ISO 8802.2. FDDI использует первый тип процедур LLC, при котором узлы работают в дейтаграммном режиме - без установления соединен ий и без восстановления потерянных или поврежденных кадров.

Рис. 2.3. Структура протоколов технологии FDDI

Физический уровень разделен на два подуровня: независимый от среды подуровень PHY (Physical), и зависящий от среды подуровень PMD (Physical Media Dependent). Работу всех уровней контролирует протокол управления станцией SMT (Station Manag ement).

Уровень PMD обеспечивает необходимые средства для передачи данных от одной станции к другой по оптоволокну. В его спецификации определяются:

  • Требования к мощности оптических сигналов и к многомодовому оптоволоконному кабелю 62.5/125 мкм;
  • Требования к оптическим обходным переключателям (optical bypass switches) и оптическим приемопередатчикам;
  • Параметры оптических разъемов MIC (Media Interface Connector), их маркировка;
  • Длина волны в 1300 нанометров, на которой работают приемопередатчики;
  • Представление сигналов в оптических волокнах в соответствии с методом NRZI.

Спецификация TP-PMD определяет возможность передачи данных между станциями по витой паре в соответствии с методом MLT-3. Спецификации уровней PMD и TP-PMD уже были рассмотрены в разделах, посвященных технологии Fast Ethernet.

Уровень PHY выполняет кодирование и декодирование данных, циркулирующих между MAC-уровнем и уровнем PMD, а также обеспечивает тактирование информационных сигналов. В его спецификации определяются:

  • кодирование информации в соответствии со схемой 4B/5B;
  • правила тактирования сигналов;
  • требования к стабильности тактовой частоты 125 МГц;
  • правила преобразования информации из параллельной формы в последовательную.

Уровень MAC ответственен за управление доступом к сети, а также за прием и обработку кадров данных. В нем определены следующие параметры:

  • Протокол передачи токена;
  • Правила захвата и ретрансляции токена;
  • Формирование кадра;
  • Правила генерации и распознавания адресов;
  • Правила вычисления и проверки 32-разрядной контрольной суммы.

Уровень SMT выполняет все функции по управлению и мониторингу всех остальных уровней стека протоколов FDDI. В управлении кольцом принимает участие каждый узел сети FDDI. Поэтому все узлы обмениваются специальными кадрами SMT для управления сетью. В спецификации SMT определено следующее:

  • Алгоритмы обнаружения ошибок и восстановления после сбоев;
  • Правила мониторинга работы кольца и станций;
  • Управление кольцом;
  • Процедуры инициализации кольца.

Отказоустойчивость сетей FDDI обеспечивается за счет управления уровнем SMT другими уровнями: с помощью уровня PHY устраняются отказы сети по физическим причинам, например, из-за обрыва кабеля, а с помощью уровня MAC - логические отказы сети, например, по теря нужного внутреннего пути передачи токена и кадров данных между портами концентратора.

В следующей таблице представлены результаты сравнения технологии FDDI с технологиями Ethernet и Token Ring.
Характеристика | FDDI | Ethernet | Token Ring
Битовая скорость | 100 Мб/с | 10 Мб/с | 16 Мб/c
Топология | Двойное кольцо деревьев | Шина/звезда | Звезда/кольцо
Метод доступа | Доля от времени оборота токена | CSMA/CD | Приоритетная система резервировани
Среда передачи данных | Многомодовое оптоволокно, неэкранированная витая пара | Толстый коаксиал, тонкий коаксиал, витая пара, оптоволокно | Экранированная и неэкранированная витая пара, оптоволокно
Максимальная длина сети (без мостов) | 200 км (100 км на кольцо) | 2500 м | 1000 м
Максимальное расстояние между узлами | 2 км (-11 dB потерь между узлами) | 2500 м | 100 м
Максимальное количество узлов | 500 (1000 соединений) | 1024 | 260 для экранированной витой пары, 72 для неэкранированной витой пары
Тактирование и восстановление после отказов | Распределенная реализация тактирования и восстановления после отказов | Не определены | Активный мо нитор

Типы узлов и правила их соединения в сеть

Все станции в сети FDDI делятся на несколько типов по следующим признакам:

  • конечные станции или концентраторы;
  • по варианту присоединения к первичному и вторичному кольцам;
  • по количеству MAC-узлов и, соответственно, MAC-адресов у одной станции.

Одиночное и двойное присоединение к сети

Если станция присоединена только к первичному кольцу, то такой вариант называется одиночным присоединением - Single Attachment, SA (рисунок 2.4, а). Если же станция присоединена и к первичному, и ко вторичному кольцам, то такой вариант называется д войным присоединением - Dual Attachment, DA (рисунок 2.4, б).

Рис. 2.4. Одиночное (SA) и двойное (DA) подключение станций

Очевидно, что станция может использовать свойства отказоустойчивости, обеспечиваемые наличием двух колец FDDI, только при ее двойном подключении.

Рис. 2.5. Реконфигурация станций с двойным подключением при обрыве кабел

Как видно из рисунка 2.5, реакция станций на обрыв кабеля заключается в изменении внутренних путей передачи информации между отдельными компонентами станции.

Количество MAC-узлов у станции

Для того, чтобы иметь возможность передавать собственные данные в кольцо (а не просто ретранслировать данные соседних станций), станция должна иметь в своем составе хотя бы один MAC-узел, который имеет свой уникальный MAC-адрес. Станции могут не иметь ни одного узла MAC, и, значит, участвовать только в ретрансляции чужих кадров. Но обычно все станции сети FDDI, даже концентраторы, имеют хотя бы один MAC. Концентраторы используют MAC-узел для захвата и генерации служебных кадров, например, кадров инициализ ации кольца, кадров поиска неисправности в кольце и т.п.

Станции, которые имеют один MAC-узел, называются SM (Single MAC) станциями, а станции, которые имеют два MAC-узла, называются DM (Dual MAC) станциями.

Возможны следующие комбинации типов присоединения и количества MAC-узлов:
SM/SA | Станция имеет один MAC-узел и присоединяется только к первичному кольцу. Станция не может принимать участие в образовании общего кольца из двух.
SM/DA | Станция имеет один MAC-узел и присоединяется сразу к первичному и вторичному кольцам. В нормальном режиме она может принимать данные только по первичному кольцу, используя второе для отказоустойчивой рабо ты.
DM/DA | Станция имеет два MAC-узла и присоединена к двум кольцам. Может (потенциально) принимать данные одновременно по двум кольцам (полнодуплексный режим), а при отказах участвовать в реконфигурации колец.
DM/SA | Станция имеет два MAC-узла, но присоединена только к первичному кольцу. Запрещенная комбинация для конечной станции, специальный случай работы концентратора.

В зависимости от того, является ли станция концентратором или конечной станцией, приняты следующие обозначения в зависимости от типа их подключения:

SAS (Single Attachment Station) - конечная станция с одиночным подключением,

DAS (Dual Attachment Station) - конечная станция с двойным подключением,

SAC (Single Attachment Concentrator) - концентратор с одиночным подключением,

DAC (Dual Attachment Concentrator) - концентратор с двойным подключением.

Типы портов станций и концентраторов FDDI и правила их соединения

В стандарте FDDI описаны четыре типа портов, которые отличаются своим назначением и возможностями соединения друг с другом для образования корректных конфигураций сетей.
Тип порта | Подключение | Назначение
A | PI/SO - (Primary In/Secondary Out) Вход первичного кольца/ Выход вторичного кольца | Соединяет устройства с двойным подключением с магистральными кольцам и
B | PO/SI - (Primary Out/Secondary In) Выход первичного кольца/Вход вторичного кольца | Соединяет устройства с двойным подключением с магистральными кольцами
M | Master - PI/PO Вход первичного кольца/Выход первичного кольца | Порт концентратора, который соединяет его с устройствами с одиночным подключением; использ ует только первичное кольцо
S | Slave - PI/PO Вход первичного кольца/Выход первичного кольца | Соединяет устройство с одиночным подключением к концентратору; использует только первичное кол ьцо

На рисунке 2.6 показано типичное использование портов разных типов для подключения станций SAS и DAS к концентратору DAC.

Рис. 2.6. Использование портов различных типов

Соединение портов S - S является допустимым, так как создает изолированное первичное кольцо, соединяющее только две станции, но обычно неиспользуемым.

Соединение портов M - M является запрещенным, а соединения A-A, B-B, A-S, S-A, B-S, S-B - нежелательными, так как создают неэффективные комбинации колец.

Соединение Dual Homing

Соединения типа A-M и B-M соответствуют случаю, так называемого, Dual Homing подключения, когда устройство с возможностью двойного подключения, то есть с портами A и B, использует их для двух подключений к первичному кольцу через порты M другого ус тройства.

Такое подключение показано на рисунке 2.7.

На нем два концентратора, DAC4 и DAC5, подключены к концентраторам DAC1, DAC2 и DAC3 по схеме Dual Homing.

Концентраторы DAC1, DAC2 и DAC3 подключены обычным способом к обеим кольцам, образуя корневую магистраль сети FDDI. Обычно такие концентраторы называют в англоязычной литературе rooted concentrators.

Концентраторы DAC4 и DAC5 подключены по древовидной схеме. Ее можно было бы образовать и с помощью концентраторов SAC4 и SAC5, которые бы в этом случае подключались бы к М-порту корневых концентраторов с помощью порта S.

Подключение DAC-концентраторов по древовидной схеме, но с использованием Dual Homing, позволяет повысить отказоустойчивость сети, и сохранить преимущества древовидной многоуровневой структуры.

Рис. 2.7. Соединение Dual Homing

Концентратор DAC4 подключен по классической схеме Dual Homing. Эта схема рассчитана на наличие у такого концентратора только одного MAC-узла. При подключении портов A и B концентратора DAC4 к портам М концентратора DAC1 между этими портами устанавливаетс физическое соединение, которое постоянно контролируется физическим уровнем PHY. Однако, в активное состояние по отношению к потоку кадров по сети переводится только порт B, а порт A остается в резервном логическом состоянии. Предпочтение, отдаваемое по у молчанию порту В, определено в стандарте FDDI.

При некорректной работе физического соединения по порту B концентратор DAC4 переводит его в резервное состояние, а активным становится порт А. После этого порт В постоянно проверяет физическое состояние его линии связи, и, если оно восстановилось, то он с нова становится активным.

Концентратор DAC5 также включен в есть по схеме Dual Homing, но с более полными функциональными возможностями по контролю соединения резервного порта А. Концентратор DAC5 имеет два узла MAC, поэтому не только порт В работает в активном режиме в первичном кольце, передавая кадры первичному MAC-узлу от порта М концентратора DAC3, но и порт А также находится в активном состоянии, принимая кадры от того же первичного кольца, но от порта М концентратора DAC2. Это позволяет вторичному MAC-узлу постоянно отслежи вать логическое состояние резервной связи.

Необходимо заметить, что устройства, поддерживающие режим Dual Homing, могут быть реализованы несколькими различными способами, поэтому может наблюдаться несовместимость этих режимов у различных производителей.

Присоединение станции к "блуждающему" MAC-узлу

Когда новая станция включается в сеть FDDI, то сеть на время приостанавливает свою работу, проходя через процесс инициализации кольца, в течение которого между всеми станциями согласуются основные параметры кольца, самым важным из которых является номинал ьное время оборота токена по кольцу. Этой процедуры в некоторых случаях можно избежать. Примером такого случая является подключение новой станции SAS к порту М концентратора с так называемым "блуждающим" узлом MAC (Roving MAC), который та кже называют локальным MAC-узлом.

Пример такого подключения показан на рисунке 2.8.

Рис. 2.8. Присоединение станции к "блуждающему" MAC-узлу

Концентратор DM/DAC1 имеет два MAC-узла: один участвует в нормальной работе первичного кольца, а второй, локальный, присоединен к пути, соединяющему порт M со станцией SAS3. Этот путь образует изолированное кольцо и используется для локальной проверки раб отоспособности и параметров станции SAS3. Если он работоспособен и его параметры не требуют реинициализации основной сети, то станция SAS3 включается в работу первичного кольца "плавно" (smooth-insertion).

Подключение станций с помощью оптических обходных переключателей (Optical Bypass Switch)

Факт отключения питания станции с одиночным подключением будет сразу же замечен средствами физического уровня, обслуживающими соответствующий М-порт концентратора, и этот порт по команде уровня SMT концентратора будет обойден по внутреннему пути прохожден ия данных через концентратор. На дальнейшую отказоустойчивость сети этот факт никакого влияния не окажет (рисунок 2.9).

Рис. 2.9. Оптический обходной переключатель (Optical Bypass Switch)

Если же отключить питание у станции DAS или концентратора DAC, то сеть, хотя и продолжит работу, перейдя в состояние Wrap, но запас отказоустойчивости будет утерян, что нежелательно. Поэтому для устройств с двойным подключением рекомендуется использовать оптические обходные переключатели - Optical Bypass Switch, которые позволяют закоротить входные и выходные оптические волокна и обойти станцию в случае ее выключения. Оптический обходной переключатель питается от станции и состоит в простейшем случае из о тражающих зеркал или подвижного оптоволокна. При отключенном питании такой переключатель обходит станцию, а при включении ее питания соединяет входы портов А и В с внутренними схемами PHY станции.

Спецификация зависящего от среды физического подуровня PMD

Структура физического соединения

Рассмотрим физический подуровень PMD (Physical Media Dependent layer), определенный в стандарте FDDI для оптоволокна - Fiber PMD.

Эта спецификация определяет аппаратные компоненты для создания физических соединений между станциями: оптические передатчики, оптические приемники, параметры кабеля, оптические разъемы. Для каждого из этих элементов указываются конструктивные и оптические параметры, позволяющие станциям устойчиво взаимодействовать на определенных расстояниях.

Физическое соединение - основной строительный блок сети FDDI. Типичная структура физического соединения представлена на рисунке 2.10.

Рис. 2.10. Физическое соединение сети FDDI

Каждое физическое соединение состоит из двух физических связей - первичной и вторичной. Эти связи являются односторонними - данные передаются от передатчика одного устройства PHY к приемнику другого устройства PHY.

Требования к мощности оптических сигналов

В стандарте Fiber PMD в явном виде не определены предельные расстояния между парой взаимодействующих устройств по одному физическому соединению.

Вместо этого в стандарте определен максимальный уровень потерь мощности оптического сигнала между двумя станциями, взаимодействующими по одной физической связи. Этот уровень равен -11 dB, где

dB = 10 log P2/P1,

причем P1 - это мощность сигнала на станции-передатчике, а P2 - мощность сигнала на входе станции-приемника. Так как мощность по мере передачи сигнала по кабелю уменьшается, то затухание получается отрицательным.

В соответствии с принятыми в стандарте Fiber PMD параметрами затухания кабеля и выпускаемыми промышленностью соединителями, считается, что для обеспечения затухания -11 dB длина оптического кабеля между соседними узлами не должна превышать 2 км.

Более точно можно рассчитать корректность физического соединения между узлами, если принять во внимание точные характеристики затухания, вносимые кабелем, разъемами, спайками кабеля, а также мощность передатчика и чувствительность приемника.

Стандарт Fiber PMD определяет следующие предельные значения параметров элементов физического соединения (называемые FDDI Power Budget):
Категория элемента | Значение
Максимальная мощность передатчика | - 14 dBm
Минимальная мощность передатчика | - 20 dBm
Максимальная принимаемая мощность | - 14 dBm
Минимальная принимаемая мощность | - 31 dBm
Максимальные потери между станциями | - 11dB
Максимальные потери на км кабеля | - 2.5 dB

Абсолютные значения мощности оптических сигналов (для выхода передатчика и для входа приемника) измеряются в децибелах по отношению к стандартной мощности в 1 милливатт (mW) и обозначаются как dBm:

dBm = 10 log P/1,

где мощность Р также измерена в милливаттах.

Из значений таблицы видно, что максимальные потери между станциями в -11 dB соответствуют наихудшему сочетанию предельных значений мощности передатчика (- 20 dBm) и приемника (- 31 dBm).

Кабели и разъемы

Основной вид кабеля для стандарта Fiber PMD - многомодовый кабель с диаметром сердечника 62.5 мкм и диаметром отражающей оболочки 125 мкм. Спецификация Fiber PMD не определяет требования к затуханию кабеля в dB на км, а только требует соблюдения требовани я по общему затуханию в -11 dB между станциями, соединенными кабелем и разъемами. Полоса пропускания кабеля должна быть не хуже чем 500 МГц на км.

Кроме основного вида кабеля, спецификация Fiber PMD допускает использование многомодовых кабелей с диаметром сердечника в 50 мкм, 85 мкм и 100 мкм.

В качестве разъемов стандарт Fiber PMD определяет оптические разъемы MIC (Media Interface Connector). Разъем MIC обеспечивает подключение 2-х волокон кабеля, соединенных с вилкой MIC, к 2-м волокнам порта станции, соединенными с розеткой MIC. Станд артизованы только конструктивные параметры розетки MIC, а любые вилки MIC, подходящие к стандартным розеткам MIC, считаются пригодными к использованию.

Спецификация Fiber PMD не определяет уровень потерь в разъеме MIC. Этот уровень - дело производителя, главное, чтобы выдерживался допустимый уровень потерь -11 dB во всем физическом соединении.

Разъемы MIC должны иметь ключ, обозначающий тип порта, что должно предотвратить неверное соединение разъемов. Определено четыре различных типа ключа:

  • MIC A;
  • MIC B;
  • MIC M;
  • MIC S.

Виды ключа для этих типов разъемов приведены на рисунке 2.11.

Рис. 2.11. Ключи разъемов MIC

Кроме разъемов MIC, допускается использовать разъемы ST и SC, выпускаемые промышленностью.

В качестве источника света допускается использование светодиодов (LED) или лазерных диодов с длиной волны 1.3 мкм.

Кроме многомодового кабеля, допускается использование более качественного одномодового кабеля (Single Mode Fiber, SMF) и разъемов SMF-MIC для этого кабеля. В этом случае дальность физического соединения между соседними узлами может увеличиться до 4 0 км - 60 км, в зависимости от качества кабеля, разъемов и соединений. Требования, определенные в спецификации SMF-PMD, для мощности на выходе передатчика и входе приемника, те же, что и для одномодового кабеля.

Функция определения сигнала уровня PMD

Спецификация на Fiber PMD требует от этого уровня выполнения функции Signal_Detect по определению факта наличия оптических сигналов на входе физического соединения станции. Этот сигнал передается на уровень PHY, где используется функцией определения стату са линии Line State Detect (рисунок 2.12).

Уровень PMD генерирует для PHY признак присутствия оптического сигнала Signal_Detect, если мощность входного сигнала превышает -43.5 dBm, а снимает его при уменьшении этой мощности до -45 dBm и ниже. Таким образом, имеется гистерезис в 1.5 dBm для предотв ращения частых изменений статуса линии при колебании входной мощности сигнала около -45 dBm.

Рис. 2.12. Функция определения сигнала на входе PMD

Физический подуровень PHY

Если в задачи подуровня PMD входит формирование качественных оптических импульсов на выходе и входе каждого физического соединения, то подуровень PHY имеет дело с передачей с помощью импульсов PMD логических единиц и нулей, приходящих с подуровня MAC. Бол ее точно, подуровень PHY занимается следующими задачами:

  • Определение моментов времени снятия информации по сигналам, поступающим от подуровня PMD (тактирование входных сигналов);
  • Определение границ байт при обмене данными с MAC-подуровнем;
  • Кодирование поступающих от MAC-подуровня символов в соответствующий физический код (NRZI или MLT-3) подуровня PMD;
  • Декодирование поступающих от PMD сигналов (NRZI или MLT-3) в символы MAC-подуровня;
  • Управление эластичным буфером (Elasticity Buffer) для согласования частоты входных и выходных сигналов;
  • Определение статуса входящей физической линии на основе тестовой последовательности управляющих символов;
  • Генерация последовательности управляющих символов для выходящей физической линии по командам от подуровня SMT;
  • Фильтрация приходящих ошибочных символов для исключения их передачи на выходную линии.

Коды 4B/5B и их прием с помощью эластичного буфера

Принципы логического кодирования с использованием кодов 4В/5В, а также физического кодирования с помощью методов NRZI (для оптоволокна) и MLT-3 (для витой пары) уже были рассмотрены в разделах 1.4.3 - 1.4.4, так как технология Fast Ethernet позаимствовала их у технологии FDDI.

Кроме 16 кодов, отведенных для 16 кодовых комбинаций исходных 4-х байтовых символов, физический и МАС-уровни оперируют нескольким служебными символами:

  • Символы состояния линии:
  • Quiet, Q (молчание) - 00000
  • Idle, I (простой) - 11111
  • Halt,I (останов) - 00100

Эти символы позволяют соседям по физическому соединению определить его состояние в процессе его инициализации и поддержани

  • Символы ограничителей начала и конца кадра:
  • Start Delimiter 1 (первый символ границы начала кадра) - 11000
  • Start Delimiter 2 (второй символ границы начала кадра) - 10001
  • Ending Delimiter (конец кадра) - 01101

Начало кадра отмечает встретившиеся подряд два символа Start Delimiter 1 и Start Delimiter 2, называемых также символами J и K (по аналогии со стандартом Token Ring)

  • Символы логического нуля и логической единицы:
  • Reset (логический нуль) - 00111
  • Set (логическая единица) - 11001

Эти символы используются для указания логических значений признаков распознавания адреса, ошибки и копирования кадра, имеющих в кадре FDDI назначение, аналогичное назначению соответствующих признаков кадра Token Ring.

  • Запрещенные символы - это все символы, которые не являются служебными кодами или 5-битными кодами, использованными для записи 16 возможных комбинаций 4-х разрядных кодов.

В обязанности физического уровня входит фильтрация символов, передаваемых на выходную линию порта. Если среди символов кадра встречаются запрещенные символы, то они заменяются на 4 символа Halt, которые далее сопровождаются символами Idle до передачи след ующего кадра. Последующий сосед, получив кадр с 4-мя символами Halt, должен изъять поврежденный кадр из кольца. Функция фильтрации не обязательна, когда кадр проходит через МАС-блок станции, но это происходит не всегда, например, вторичное кольцо может пр оходить только через блоки физического уровня, не заходя в МАС-блок, если это станция с двойным подключением.

Рассмотрим подробней, каким образом происходит синхронизация приемника с передатчиком в сети FDDI при приеме кодов 4B/5В.

Сеть FDDI использует распределенную схему тактирования информации, при которой каждая станция работает со своим независимым локальным тактовым генератором. Это отличает ее от сетей Token Ring, в которых одна станция поддерживает тактирование информации дл я всей сети, управляя главным тактовым генератором сети, называемым Master Clock.

В сети FDDI тактовые частоты синхронизируются в каждом физическом соединении соседних станций (рисунок 2.13).

Рис. 2.13. Согласование тактовых генераторов в сети FDDI

Каждая станция имеет два тактовых генератора - локальный, который управляет тактированием передаваемой информации, и восстанавливающим, который синхронизируется с тактовой частотой данных, приходящих от соседней станции. Локальный тактовый генератор работ ает на тактовой частоте 125 Мгц ± 0.005%. Восстанавливающий тактовый генератор, называемый RCRCLK (Receive Recovery Clock) подстраивается под тактовую частоту, извлекаемую из NRZI или MLT-3 сигналов при поступлении кодов Idle в промежутке между передачей кадров данных. Коды Idle, имеющие значение 111111, создают последовательность импульсов типа "меандр" с равными длительностями высокого и низкого потенциала, удобных для подстройки тактового генератора RCRCLK, так как сигнал изм еняется два раза за период.

Поступающие символы записываются в соответствии с обнаруженной в импульсах кодов Idle частотой в эластичный буфер (Elasticity Buffer). Из эластичного буфера символы извлекаются уже с частотой локального генератора. В результате, рассогласование частот ста нций в кольце постоянно сглаживается, не превышая 0.01%. Принимающая станция поддерживает заполнение эластичного буфера наполовину, извлекая очередной символ только при превышении этой границы.

Процедура установления физического соединения

Блоки PMD и PHY, реализующие физический уровень технологии FDDI для каждого порта, участвуют в процедуре инициализации физического соединения каждого порта станции с портом предшествующей или последующей станций. Эта процедура проводится при непосредствен ном участии блока управления станцией - SMT (Station Management). Блок управления станцией выполняет большое количество функций, получая информацию и управляя всеми остальными блоками станции - PMD, PHY и MAC. Рассмотрим группу функций SMT, управл ющих физическими соединениями портов и конфигурацией внутреннего пути данных. Эта группа функций получила название Connection Management (CMT).

На рисунке 2.14 показан состав функций CMT и связь их с блоками PMD, PHY, MAC и некоторыми другими элементами станции.

Рис. 2.14. Структура блока управления конфигурацией CMT

Станция, имеющая несколько портов, обеспечивает для каждого из них блоки PMD, PHY и элемент управления конфигурацией CCE (Control Configuration Element). ССЕ - это переключатель, который соединяет входы и выходы первичного и вторичного колец, подкл юченных к порту извне, с внутренними путями данных станции, в результате данные могут передаваться из порта элементу MAC станции, а могут непосредственно переправляться на другой порт. Реконфигурация станции при ее реакции на отказы производится именно пе реключателем CCE.

Блок управления конфигурацией имеет в своем составе несколько элементов PCM (Physical Connection Management), по одному на каждый порт. Элемент PCM управляет физическим состоянием линии своего порта, анализируя символы, приходящие от PHY, и передав ая PHY свои команды. Если элемент PCM обнаруживает изменение состояния линии, то он оповещает об этом элемент CFM (Configuration Management), который отвечает за конфигурацию внутреннего пути данных. Элемент CFM производит конфигурирование внутренн его пути, управляя переключателями портов CCE. Делает он это с помощью элементов CEM (Configuration Element Management), каждый из которых управляет одним переключателем CCE. Блок ECM (Entity Coordination Management) координирует работу всех блоков и элементов блока управления конфигурацией CMT.

Установление физического соединения - основная задача блока PCM. Блок PCM каждого порта начинает эту процедуру по команде PC_Start, получаемой от координирующего элемента ECM (рисунок 2.15).

Рис. 2.15. Управление физическим соединением портов

При получении этой команды блок PCM локального порта начинает обмениваться символами кодов 4B/5B по миникольцу, образуемому двумя соседними портами. Процедура инициализации физического соединения - это распределенная процедура, в ней участвуют два РСM сос едних портов.

Во время этой процедуры для обмена информацией соседние порты используют не отдельные символы, а достаточно длинные последовательности символов, что повышает надежность взаимодействия. Эти последовательности называются состоянием линии. Всего используетс 4 состояния линии:

  • Quiet Line State, QLS - состояние молчания, состоит в передаче 16 или 17 символов Quiet подряд;
  • Master Link State, MLS - состояние главного порта, состоит в передаче 8 или 9 пар символов Halt-Quiet;
  • Halt Link State, HLS - состояние останова, состоит в передаче 16 или 17 символов Halt подряд;
  • Idle Link State, ILS - состояние простоя, состоит в передаче 16 или 17 символов Idle подряд.

Первый этап инициализации заключается в передаче портом - инициатором соединения - состояния QLS соседнему порту. Тот должен при этом перейти в состояние BREAK - разрыва связи, независимо от того, в каком состоянии связь находилась до получения символов Q LS. Соседний порт, перейдя в состояние BREAK, также посылает символы QLS, обозначая свой переход.

После того, как порт-инициатор убедился, что первый этап инициализации выполнен, он выполняет следующий этап - переход в состояние CONNECT (соединение). Делает он это посылкой символов HLS, на что соседний порт также должен ответить символами HLS.

Если состояние CONNECT установлено, то порт-инициатор начинает наиболее содержательный этап инициализации - NEXT, включающий обмен информацией о типе портов, проведение тестирования качества линии и проведение тестового обмена МАС-кадрами. Этап NEXT состо ит в обмене между соседними портами 10-ю сообщениями, которые передаются по очереди. Порт передает одно свое сообщение, затем получает и анализирует сообщение от соседа и так далее. Каждое сообщение несет один бит информации и кодируется последовательност ями MLS - логический ноль, или HLS - логическая единица.

Первые два сообщения несут информацию о типе своего порта. Для кодирования нужны два бита, так как существует четыре типа портов - А, В, М или S. Третье сообщение говорит соседнему порту, приемлемо ли для данного порта соединение с указанным в принятых со общениях типом порта. Если да, то следующие сообщения оговаривают длительность процедуры тестирования качества линии, а затем передают информацию о результатах тестирования. Тест состоит в передаче в течение определенного времени символов Idle и подсчете искаженных символов. Если качество линии приемлемо, то выполняется тестовый обмен кадрами данных с участием блоков MAC станций.

Если все этапы инициализации прошли успешно, то физическое соединение считается установленным и активным. По нему начинают передаваться символы простоя и кадры данных. Однако, до тех пор, пока станция не выполнит процедуру логического вхождения станции в кольцо, эти кадры могут нести только служебную информацию.

Конфигурирование внутреннего пути

После установления физического соединения станция должна включить порт во внутренний путь, по которому проходят кадры данных и маркер.

Средством, с помощью которого выполняется это включение, является переключатель CCE. Он может подключить вход и выход порта к любому из трех внутренних путей станции (рисунок 2.16) по командам от элемента CEM блока управления конфигурацией CMT.

Рис. 2.16. Подключение порта к внутренним путям станции

Внутренние пути станции не следует путать с внешними первичным и вторичным кольцами сети. Внутренние пути могут соединяться с любым из колец, в зависимости от состояния порта.

Первичный внутренний путь обязательно должен присутствовать у любой станции. Вторичный внутренний путь является необязательным, но желательным в некоторых конфигурациях станций с двойным подключением, как это будет видно из примеров. Локальный путь исполь зуется для тестирования станции на МАС-уровне перед ее логическим включением в кольцо.

Переключатель CCE может находиться в одном из 5 состояний (рисунок 2.17):

  • ISOLATED - изолированное состояние, когда все пути идут мимо входа и выхода порта;
  • INSERT_P - порт включен в первичный внутренний путь;
  • INSERT_S - порт включен во вторичный внутренний путь;
  • INSERT_X - порт включен в первичный и вторичный внутренние пути. Это состояние используется для сворачивания первичного и вторичного внешних колец на данном порту (состояние WRAP сети);
  • LOCAL - порт включен в локальный внутренний путь.

Рис. 2.17. Состояния переключателя внутренних путей

С помощью перевода переключателей портов станции в нужное состояние блок управления конфигурацией может обеспечить передачу кадров и маркера по тому внутреннему пути, который соответствует текущему состоянию сети. На рисунке 2.18 приведены примеры поддерж ки состояний THRU_A ( а) и WRAP_A (б) для станции с двойным подключением.

Состояние THRU_A соответствует нормальному режиму работы колец сети. В этом режиме первичное кольцо проходит через порты А и В, а также MAC-узел станции, а вторичное кольцо проходит только через блоки PMD и PHY каждого из портов. Состояние WRAP_A соответс твует реакции сети на нарушение целостности сети, при котором порт В теряет физическое соединение с соседним по сети портом. При этом на линии устанавливается состояние Quiet Line State, так как отсутствие сигналов на входе порта соответствует получению с имволов Quiet (00000). Получив информацию о том, что на входе порта В установилось состояние QLS, блок PCM этого порта пытается начать процесс реинициализации физического соединения. При отсутствии физической связи между портами эта попытка называется уда чной, поэтому порт переводится в состояние INSERT_X, а порт В - в состояние ISOLATED.

Рис. 2.18. Работа переключателя пути CCE в станции с двойным подключением

МАС-уровень

Функции МАС-уровня

В соответствии со стандартами IEEE 802 канальный уровень в локальных сетях состоит из двух подуровней - LLC и МАС. Стандарт FDDI не вводит свое определение подуровня LLC, а использует его сервисы, описанные в документе IEEE 802.2 LLC.

Подуровень МАС выполняет в технологии FDDI следующие функции:

  • Поддерживает сервисы для подуровня LLC;
  • Формирует кадр определенного формата;
  • Управляет процедурой передачи токена;
  • Управляет доступом станции к среде;
  • Адресует станции в сети;
  • Копирует кадры, предназначенные для данной станции, в буфер и уведомляет подуровень LLC и блок управления станцией SMT о прибытии кадра;
  • Генерирует контрольную последовательность кадра (CRC) и проверяет ее у всех кадров, циркулирующих по кольцу;
  • Удаляет из кольца все кадры, которые сгенерировала данная станция;
  • Управляет таймерами, которые контролируют логическую работу кольца - таймером удержания токена, таймером оборота токена и т.д.;
  • Ведет ряд счетчиков событий, что помогает обнаружить и локализовать неисправности;
  • Определяет механизмы, используемые кольцом для реакции на ошибочные ситуации - повреждение кадра, потерю кадра, потерю токена и т.д.

В данном разделе для иллюстрации работы МАС-уровня будет использоваться в качестве иллюстрации станция с двойным подключением и одним блоком МАС, то есть станция DA/SM. Ее внутренняя структура показана на рисунке 2.19.

Рис. 2.19. Внутренняя структура станции с двойным подключением и одним блоком МАС

В каждом блоке МАС параллельно работают два процесса: процесс передачи символов - MAC Transmit и процесс приема символов - MAC Receive. За счет этого МАС может одновременно передавать символы одного кадра и принимать символы другого кадра.

Форматы кадра и токена

По сети FDDI информация передается в форме двух блоков данных: кадра и токена. Формат кадра FDDI представлен на рисунке 2.20.

Рис. 2.20. Формат кадра FDDI

Рассмотрим назначение полей кадра.

  • Преамбула (Preamble, PA). Любой кадр должен предваряться преамбулой, состоящей как минимум из 16 символов Idle (I). Эта последовательность предназначена для вхождения в синхронизм генератора RCRCLK, обеспечивающего прием последующих символов кадра.
  • Начальный ограничитель (Starting Delimiter, SD). Состоит из пары символов JK, которые позволяют однозначно определить границы для остальных символов кадра.
  • Поле управления (Frame Control, FC). Идентифицирует тип кадра и детали работы с ним. Имеет 8-ми битовый формат и передается с помощью двух символов. Состоит из подполей, обозначаемых как CLFFZZZZ, которые имеют следующее назначение:
  • С - говорит о том, какой тип трафика переносит кадр - синхронный (значение 1) или асинхронный (значение 0);
  • L - определяет длину адреса кадра, который может состоять из 2-х байт или из 6-ти байт;
  • FF - тип кадра, может иметь значение 01 для обозначения кадра LLC (пользовательские данные) или 00 для обозначения служебного кадра MAC-уровня. Служебными кадрами МАС-уровня являются кадры трех типов - кадры процедуры инициализации кольца Claim Frame, кадры процедуры сигнализации о логической неисправности Beacon Frame и кадры процедуры управления кольцом SMT Frame;
  • ZZZZ - детализирует тип кадра.
  • Адрес назначения (Destination Address, DA) - идентифицирует станцию (уникальный адрес) или группу станций (групповой адрес), которой(ым) предназначен кадр. Может состоять из 2-х или 6-ти байт.
  • Адрес источника (Source Address, SA) - идентифицирует станцию, сгенерировавшую данный кадр. Поле должно быть той же длины, что и поле адреса назначения.
  • Информация (INFO) - содержит информацию, относящуюся к операции, указанной в поле управления. Поле может иметь длину от 0 до 4478 байт (от 0 до 8956 символов). Стандарт FDDI допускает размещение в этом поле маршрутной информации алгоритма Source Routi ng, определенной в стандарте 802.5. При этом в два старших бита поля адреса источника SA помещается комбинация 102 - групповой адрес, комбинация, не имеющая смысла для адреса источника, а обозначающая присутствие маршрутной информации в поле данных.
  • Контрольная последовательность (Frame Check Sequence, FCS) - содержит 32-х битную последовательность, вычисленную по стандартному методу CRC-32, принятому и для других протоколов IEEE 802. Контрольная последовательность охватывает поля FC, DA, SA, INF O и FCS.
  • Конечный ограничитель (Ending Delimiter, ED) - содержит единственный символ Terminate (T), обозначающий границу кадра. Однако за ним располагаются еще признаки статуса кадра.
  • Статус кадра (Frame Status, FS). Первые три признака в поле статуса должны быть индикаторами ошибки (Error, E), распознавания адреса (Address recognized, A) и копирования кадра (Frame Copied, C). Каждый из этих индикаторов кодируется одним символом, п ричем нулевое состояние индикатора обозначается символом Reset (R), а единичное - Set (S). Стандарт позволяет производителям оборудования добавлять свои индикаторы после трех обязательных.

На рисунке 2.21 показан формат токена.

Рис. 2.21. Формат токена

Токен состоит по существу из одного значащего поля - поля управления, которое содержит в этом случае 1 в поле С и 0000 в поле ZZZZ.

Операции МАС-уровня

С помощью операций МАС-уровня станции получают доступ к кольцу и передают свои кадры данных. Цикл передачи кадра от одной станции к другой состоит из нескольких этапов: захвата токена станцией, которой необходимо передать кадр, передачей одного или нескол ьких кадров данных, освобождением токена передающей станцией, ретрансляцией кадра промежуточными станциями, распознаванием и копированием кадра станцией-получателем и удалением кадра из сети станцией-отправителем.

Рассмотрим эти операции.

Захват токена. Если станция имеет право захватить токен, то она после ретрансляции на выходной порт символов PA и SD токена, удаляет из кольца символ FC, по которому она распознала токен, а также конечный ограничитель ED. Затем она передает вслед з а уже переданным символом SD символы своего кадра, таким образом, формируя его из начальных символов токена (рисунок 2.22).

Рис. 2.22. Захват токена

Передача кадра. После удаления полей FC и ED токена станция начинает передавать символы кадров, которые ей предоставил для передачи уровень LLC. Станция может передавать кадры до тех пор, пока не истечет время удержания токена.

Для сетей FDDI предусмотрена передача кадров двух типов трафика - синхронного и асинхронного.

Синхронный трафик предназначен для приложений, которые требуют предоставления им гарантированной пропускной способности для передачи голоса, видеоизображений, управления процессами и других случаев работы в реальном времени. Для такого трафика кажд ой станции предоставляется фиксированная часть пропускной способности кольца FDDI, поэтому станция имеет право передавать кадры синхронного трафика всегда, когда она получает токен от предыдущей станции.

Асинхронный трафик - это обычный трафик локальных сетей, не предъявляющий высоких требований к задержкам обслуживания. Станция может передавать асинхронные кадры только в том случае, если при последнем обороте токена по кольцу для этого осталась ка кая-либо часть неизрасходованной пропускной способности. Интервал времени, в течение которого станция может передавать асинхронные кадры, называется временем удержания токена (Token Holding Time, THT). Каждая станция самостоятельно вычисляет текуще е значение этого параметра по алгоритму, рассмотренному ниже.

Рисунок 2.23 иллюстрирует процесс передачи кадра.

Рис. 2.23. Передача кадра

В ходе передачи символов собственного кадра станция удаляет из кольца все поступающие от предыдущей станции символы. Такой процесс называется МАС-заменой (MAC Overwriting). Первоначальный источник удаляемого из сети кадра не имеет значения - это может быт ь и данный МАС-узел, который ранее поместил этот кадр в кольцо, либо другой МАС-узел. Процесс удаления кадров во время передачи никогда не приводит к удалению еще необработанных кадров: если сеть работает корректно, то удаляются только усеченные кадры, ко торые образуются либо при захвате токена (этот вариант уже рассмотрен), либо при удалении своего кадра станцией-источником (этот вариант будет рассмотрен ниже). В любом случае, усеченный кадр (remnant frame) - это кадр, у которого есть начальный ограничит ель, но отсутствует конечный ограничитель, а вместо него и, может быть, еще некоторых полей вставлены символы простоя Idle.

В случае, если удаляемые символы принадлежат кадру, ранее сгенерированному данным МАС-узлом, то одновременно с удалением кадра из кольца проверяются признаки статуса кадра из поля FS - распознавания адреса, копирования и ошибки. Если признак ошибки устано влен, то МАС-уровень не занимается повторной передачей кадра, оставляя это уровню LLC или другим верхним уровням коммуникационного стека протоколов.

Станция прекращает передачу кадров в двух случаях: либо при истечении времени удержания токена THT, либо при передаче всех имеющихся у нее кадров до истечения этого срока. После передачи последнего своего кадра станция формирует токен и передает его следу ющей станции.

Повторение кадра. Если кадр не адресуется данному МАС-узлу, то последний должен просто повторить каждый символ кадра на выходном порту. Каждый МАС-узел должен подсчитывать количество полученных им полных кадров (усеченные не включаются в подсчет). Каждая станция проверяет повторяемый кадр на наличие ошибок с помощью контрольной последовательности. Если ошибка обнаружена, а признак ошибки в поле FS не установлен, то МАС-узел устанавливает этот признак в кадре, а также наращивает счетчик ошибочных ка дров, распознанных данным МАС-узлом.

Обработка кадра станцией назначения. Станция назначения, распознав свой адрес в поле DA, начинает копировать символы кадра во внутренний буфер одновременно с повторением их на выходном порту. При этом станция назначения устанавливает признак распоз навания адреса. Если же кадр скопирован во внутренний буфер, то устанавливается и признак копирования (невыполнение копирования может произойти, например, из-за переполнения внутреннего буфера). Устанавливается также и признак ошибки, если ее обнаружила п роверка по контрольной последовательности.

Удаление кадра из кольца. Каждый МАС-узел ответственен за удаление из кольца кадров, которые он ранее в него поместил. Этот процесс известен под названием Frame Stripping. Если МАС-узел при получении своего кадра занят передачей следующих ка дров, то он удаляет все символы вернувшегося по кольцу кадра. Если же он уже освободил токен, то он повторяет на выходе несколько полей этого кадра прежде, чем распознает свой адрес в поле SA. В этом случае в кольце возникает усеченный кадр, у которого по сле поля SA следуют символы Idle и отсутствует конечный ограничитель. Этот усеченный кадр будет удален из кольца какой-нибудь станцией, принявшей его в состоянии собственной передачи.

Инициализация кольца

Процедура инициализации кольца, известная под названием Claim Token (это название в свободном переводе можно может интерпретироваться как "соревнование претендентов на генерацию токена"), выполняется для того, чтобы все станции кольца убедились в е го потенциальной работоспособности, а также пришли к соглашению о значении параметра T_Opr - максимально допустимому времени оборота токена по кольцу, на основании которого все станции вычисляют время удержания токена THT.

Процедура Claim Token выполняется в нескольких ситуациях:

  • При включении новой станции в кольцо и при выходе станции из кольца.
  • При обнаружении какой-либо станцией факта утери токена. Токен считается утерянным, если станция не наблюдает его в течение двух периодов времени максимального оборота токена T_Opr.
  • При обнаружении длительного отсутствия активности в кольце, когда станция в течение определенного времени не наблюдает проходящих через нее кадров данных.
  • По команде от блока управления станцией SMT.

Для выполнения процедуры инициализации каждая станция сети должна знать о своих требованиях к максимальному времени оборота токена по кольцу. Эти требования содержатся в параметре, называемом "требуемое время оборота токена" - TTRT (Target Token Rotati on Time). Параметр TTRT отражает степень потребности станции в пропускной способности кольца - чем меньше время TTRT, тем чаще станция желает получать токен для передачи своих кадров. Процедура инициализации позволяет станциям узнать о требованиях ко времени оборота токена других станций и выбрать минимальное время в качестве общего параметра T_Opr, на основании которого в дальнейшем будет распределяться пропускная способность кольца. Параметр TTRT должен находиться в пределах от 4 мс до 165 мс и може т изменяться администратором сети.

Для проведения процедуры инициализации станции обмениваются служебными кадрами МАС-уровня - кадрами Claim. Эти кадры имеют в поле управления значение 1L00 0011, поле адреса назначения содержит адрес источника (DA = SA), а в поле информации содержится 4-х байтовое значение запрашиваемого времени оборота токена T_Req.

Если какая-либо станция решает начать процесс инициализации кольца по своей инициативе, то она формирует кадр Claim Token со своим значением требуемого времени оборота токена TTRT, то есть присваивает полю T_Req свое значение TTRT. Захвата токена для отпр авки кадра Claim не требуется. Любая другая станция, получив кадр Claim Token, начинает выполнять процесс Claim Token. При этом станции устанавливают признак нахождения кольца в работоспособном состоянии Ring_Operational в состояние False, что означает от мену нормальных операций по передаче токена и кадров данных. В этом состоянии станции обмениваются только служебными кадрами Claim.

Для выполнения процедуры инициализации каждая станция поддерживает таймер текущего времени оборота токена TRT (Token Rotation Timer), который используется также и в дальнейшем при работе кольца в нормальном режиме. Для упрощения изложения будем считать, ч то этот таймер, как и другие таймеры станции, инициализируется нулевым значением и затем наращивает свое значение до определенной величины, называемой порогом истечения таймера. (В реальном кольце FDDI все таймеры работают в двоичном дополнительном коде).

Таймер TRT запускается каждой станцией при обнаружении момента начала процедуры Claim Token. В качестве предельного значения таймера выбирается максимально допустимое время оборота токена, то есть 165 мс. Истечение таймера TRT до завершения процедуры озна чает ее неудачное окончание - кольцо не удалось инициализировать. В случае неудачи процесса Claim Token запускается процессы Beacon и Trace, с помощью которых станции кольца пытаются выявить некорректно работающую часть кольца и отключить ее от сети.

Во время выполнения процесса Claim Token каждая станция сначала может отправить по кольцу кадр Claim со значением T_Req, равным значению ее параметра TTRT. При этом она устанавливает значение T_Opr, равное значению TTRT. Рассмотрим пример инициализируемог о кольца, приведенный на рисунке 2.24.

Рис. 2.24. Процесс инициализации кольца

В некоторый момент времени все станции передали по кольцу свои предложения о значении максимального времени оборота токена: 72 мс, 37 мс, 51 мс и 65 мс. Станция, приняв кадр Claim от предыдущей станции, обязана сравнить значение T_Req, указанное в кадре с о значением TTRT своего предложения. Если другая станция просит установить время оборота токена меньше, чем данная (то есть T_Req < TTRT), то данная станция перестает генерировать собственные кадры Claim и начинает повторять чужие кадры Claim, так как видит, что в кольце есть более требовательные станции. Одновременно станция фиксирует в своей переменной T_Opr минимальное значение T_Req, которое ей встретилось в чужих кадрах Claim. Если же пришедший кадр имеет значение T_Req больше, чем собственное зна чение TTRT, то он удаляется из кольца.

Процесс Claim завершается для станции в том случае, если она получает кадр Claim со своим адресом назначения. Это означает, что данная станция является победителем состязательного процесса и ее значение TTRT оказалось минимальным. В рассматриваемом пример е это станция B со значением TTRT, равным 37 мс. Другие станции кольца не смогут получить свой кадр Claim, так как он не сможет пройти через станцию B. При равных значениях параметра TTRT преимущество отдается станции с большим значением МАС-адреса.

После того, как станция обнаруживает, что она оказалась победителем процесса Claim Token, она должна сформировать токен и отправить его по кольцу. Первый оборот токена - служебный, так как за время этого оборота станции кольца узнают, что процесс Claim To ken успешно завершился. При этом они устанавливают признак Ring_Ope-
rational в состояние True, означающее начало нормальной работы кольца. При следующем проходе токена его можно будет использовать для захвата и передачи кадров данных.

Если же у какой-либо станции во время выполнения процедур инициализации таймер TRT истек, а токен так и не появился на входе станции, то станция начинает процесс Beacon.

После нормального завершения процесса инициализации у всех станций кольца устанавливается одинаковое значение переменной T_Opr.

Управление доступом к кольцу

Управление доступом к кольцу FDDI распределено между его станциями. Каждая станция при прохождении через нее токена самостоятельно решает, может она его захватить или нет, а если да, то на какое время.

Если у станции имеются для передачи синхронные кадры, то она всегда может захватить токен на фиксированное время, выделенное ей администратором.

Если же у станции имеются для передачи асинхронные кадры, то условия захвата определяются следующим образом.

Станция ведет уже упомянутый таймер текущего времени оборота токена TRT, а также счетчик количества опозданий токена Late_Ct. Время истечения таймера TRT равно значению максимального времени оборота токена T_Opr, выбранному станциями при инициализации кол ьца.

Счетчик Late_Ct всегда сбрасывается в нуль, когда токен проходит через станцию. Если же токен опаздывает, то таймер достигает значения T_Opr раньше очередного прибытия токена. При этом таймер обнуляется и начинает отсчет времени заново, а счетчик Late_Ct наращивается на единицу, фиксируя факт опоздания токена. При прибытии опоздавшего токена (при этом Late_Ct = 1) таймер TRT не сбрасывается в нуль, а продолжает считать, накапливая время опоздания токена. Если же токен прибыл раньше, чем истек интервал T_O pr у таймера TRT, то таймер сбрасывается в момент прибытия токена.

На рисунке 2.25 приведены различные случаи прибытия токена. Значение максимального времени оборота токена для примера, приведенного на этом рисунке, равно 30 мс.

Рис. 2.25. Поведение таймера времени текущего оборота токена TRT
и счетчика опозданий токена Late_Ct

Приведенный пример иллюстрирует следующие события:
Момент А: | Токен прибыл вовремя, так как таймер TRT не достиг порога T_Opr. Таймер TRT перезапускается и начинает считать заново.
Момент В: | Токен прибыл вовремя. Таймер перезапускается.
Момент С: | Таймер истек раньше, чем токен прибыл на станцию. Таймер TRT перезапускается, а счетчик Late_Ct наращивается на единицу.
Момент D: | Токен наконец прибыл, но он опоздал - это отмечает счетчик Late_Ct, равный 1. Счетчик сбрасывается в нуль, но таймер не перезапускается, так как при приходе токена счетчик не был равен нулю.
Момент Е: | Токен прибыл на станцию. Так как он прибыл до истечения таймера и при нулевом значении счетчика Late_Ct, то считается, что он прибыл вовремя. Таймер перезапускается.

Теперь рассмотрим, каким образом значения таймера TRT и счетчика Late_Ct используются при выяснении возможности захвата токена и времени его удержания.

Станция может захватывать токен только в том случае, когда он прибывает вовремя - то есть в момент его прибытия счетчик Late_Ct равен нулю.

Время удержания токена управляется таймером удержания токена THT (Token Holding Timer). Если станция имеет в буфере кадры для передачи в момент прибытия токена и токен прибыл вовремя, то станция захватывает его и удерживает в течение периода (T_Opr - TRT), где TRT - значение таймера TRT в момент прихода токена. Для отслеживания разрешенного времени удержания токена в момент захвата токена значение TRT присваивается таймеру THT, а затем таймер TRT обнуляется и перезапускается. Таймер THT считает до границы T_Opr, после чего считается, что время удержания токена исчерпано. Станция перестает передавать кадры данных и передает токен.

Описанный алгоритм позволяет адаптивно распределять пропускную способность кольца между станциями, а точнее - ту ее часть, которая осталась после распределения между синхронным трафиком станций.

Пример работы алгоритма выделения времени для передачи асинхронного трафика приведен на рисунке 2.26. как и в предыдущем примере, время максимального оборота токена равно 30 мс.

Рис. 2.26. Выделение времени для асинхронного трафика

Рассмотрим события, иллюстрируемые примером:
Момент А: | Токен прибыл вовремя, так как таймер TRT не достиг порога T_Opr. Таймер TRT перезапускается и начинает считать заново. Станция не имеет в это время асинхронных кадров, поэтому просто передае т токен соседу.
Момент В: | Токен прибыл вовремя. Станция имеет к этому моменту асинхронные кадры для передачи. Таймеру THT присваивается значение таймера TRT (16), и он начинает считать до значения T_Opr (30). Таймер TRT перезапускается. Станция начинает передавать кадры. Она может это делать в течение 14 мс. Если она закончит передачу имеющихся кадров раньше, то она обязана немедленно освободить токен.
Момент С: | Таймер THT истек, и станция должна прекратить передачу асинхронных кадров. Станция завершает передачу текущего кадра и передает токен соседней станции. Счетчик TRT при этом продолжает работа ть.
Момент D: | Таймер TRT истекает раньше очередного прибытия токена. Таймер перезапускается, а счетчик Late_Ct наращивается на 1.
Момент Е: | Токен прибывает, но он опоздал, так как Late_Ct имеет значение 1. Станция не может захватить токен при значении Late_Ct, отличном от нуля. Токен передается соседней станции. Счетчик Late_ Ct обнуляется, а таймер TRT не перезапускается.
Момент F: | Токен прибывает на станцию. Так как таймер TRT еще не истек, а значение Late_Ct равно 0, то токен прибыл вовремя. Таймер THT инициализируется значением таймера TRT (22) и начинает считать д о границы T_Opr. TRT перезапускается. Станция может передавать кадры в течение 8 мс.
Момент G: | Таймер THT истекает, и передача асинхронных кадров прекращается. Станция передает токен соседней станции.

В стандарте FDDI определено также еще два механизма управления доступом к кольцу. Во-первых, в токене можно задавать уровень приоритета токена, а для каждого уровня приоритета задается свое время порога, до которого считает таймер удержания токена THT. Во -вторых, определена особая форма токена - сдерживающий токен (restricted token), с помощью которого две станции могут монопольно некоторое время обмениваться данными по кольцу.

Если таймер TRT истечет при значении Late_Ct, равном 1, то такое событие считается потерей токена и порождает выполнение процесса реинициализации кольца Claim Token.

Управление в сетями FDDI с помощью спецификации SMT

Общая характеристика функций управления сетью по спецификации SMT

Кроме спецификаций уровней PHY, PMD и МАС, стандарт FDDI определяет также спецификацию уровня управления станцией Station Management (SMT). В настоящее время действует версия 7.3 SMT.

Эта спецификация определяет функции, которые должен выполнять каждый узел в сети FDDI. SMT контролирует и управляет всеми процессами канального и физического уровней, протекающими в отдельной станции. Кроме того, процесс SMT каждой станции взаимодействует с аналогичными процессами других станций для того, чтобы следить и координировать все операции в кольце FDDI. В этом случае SMT принимает участие в распределенном одноранговом управлении кольцом.

SMT включает три группы функций (рисунок 2.27):

  • Управление соединениями - Connection Management (CMT);
  • Управление кольцом - Ring Management (RMT);
  • Управление, основанное на кадрах - Frame-Based Management (FBM).

Рис. 2.27. Состав функций управления SMT

Функции управления соединениями CMT уже были рассмотрены в разделах 2.5.2 и 2.5.3 в связи с тем, что их основным назначением является контроль и управление физическими соединениями, организуемыми физическим уровнем.

Функции управления кольцом RMT заключаются в управлении локальными узлами МАС и кольцами, к которым они присоединены. Функции RMT ответственны за обнаружение дублированных адресов, а также за запуск процедуры инициации кольца Claim Token и п роцедур обработки аварийных ситуаций Beacon и Trace.

Функции управления, основанного на кадрах FBM позволяют узлу получать от других узлов сети информацию о их состоянии и статистике о прошедшем через них трафике. Эта информация хранится в базе данных управляющей информации MIB (Management Informatio n Base).

Функции управления кольцом RMT

Для выполнения своих функций узел RMT взаимодействует с локальным узлом МАС, узлом управления соединениями CMT, а также другими узлами SMT станции. Узел RMT выполняет следующие функции:

Уведомление о статусе и наличии локального МАС-узла. RMT несет ответственность за уведомление других узлов SMT о:

  • доступности МАС узла для передачи и приема кадров и токена;
  • начале или завершении процесса Beacon в локальном узле;
  • обнаружении факта дублирования МАС-адреса;
  • старте функции Trace, позволяющей узлу выйти из состояния постоянной генерации кадров сигнализации о неисправности (состояние Stuck Beacon);
  • неработоспособности кольца в течение длительного времени.

Процесс Beacon и выход из него. Процесс Beacon (процесс сигнализации) используется для изоляции серьезных повреждений кольца. Узел МАС начинает процесс Beacon в следующих ситуациях:

  • процесс инициализации кольца Claim Token не завершился за отведенное ему время;
  • узел SMT передал узлу MAC команду на инициацию процесса Beacon.

Если узел входит в процесс Beacon, то он начинает передавать последующему в кольце узлу кадры Beacon, в которых в качестве адреса назначения указывается либо 0, либо адрес предшествующей станции, полученный в этом случае от SMT. В поле данных пересылаетс один байт причины начала процесса Beacon (0 - неудачное завершение процесса Claim Token, остальные значения зарезервированы на будущее).

Если же узел получает кадр Beacon от другой станции, то она прекращает передавать свои кадры Beacon и переходит в режим повторения кадров.

Через некоторое время после возникновения аварийной ситуации в кольце все станции прекращает генерировать кадры Beacon, кроме одной, той, которая находится в кольце непосредственно за станцией или участком кабеля, являющимися причиной аварийной ситуации в кольце. Станция, продолжающая генерировать кадры Beacon, попадает в состояние Stuck Beacon - "постоянной сигнализации" (рисунок 2.28).

Рис. 2.28. Станция в состоянии Stuck Beacon

Процесс RMT каждой станции при входе станции в процесс Beacon запускает таймер TRM (Ring Management), который измеряет период времени, в течение которого данная станция генерирует кадры Beacon. При превышении им границы T_Stuck процесс RMT считает, что станция попала в состояние постоянной сигнализации Stuck Beacon и что узел управления конфигурацией не смог справиться с возникшей в кольце проблемой.

В этой ситуации узел RMT посылает по кольцу так называемый направленный сигнальный кадр - Directed Beacon - станции управления кольца (подразумевается, что на одной из станций кольца выполняется специальное программное обеспечение управления сетью, например, Sun NetManager, не входящее в компетенцию стандарта FDDI). В качестве адреса назначения в кадре Directed Beacon указывается специальный групповой адрес, который станция управления должна распознать. Поле информации должно содержать адрес предше ствующей станции - потенциального виновника проблемы.

После передачи нескольких кадров Directed Beacon (для надежности) процесс RMT инициирует процесс Trace.

Процесс Trace используется для обнаружения домена неисправности - то есть группы станций, которые работают некорректно.

Станция, которая инициирует процесс Trace, посылает об этом сигнал станции, непосредственно предшествующей ей в кольце - то есть предыдущему соседу. Сигнал Trace передается в форме последовательности символов Halt и Quiet.

Станция, которая получила сигнал Trace, и станция, которая передала сигнал Trace, на некоторое время отключаются от кольца и выполняют тест проверки внутреннего пути, так называемый Path Test. Детали теста Path Test не определены спецификацией SMT. Ее общее назначение состоит в том, что станция должна автономно проверить передачу символов и кадров между всеми своими внутренними узлами, чтобы убедиться в том, что не она является причиной отказа кольца.

Если тест внутреннего пути Path Test выполнен успешно, то процесс SMT посылает блокам управления конфигурацией сигнал PC_Start, по которому они начинают восстановление физических соединений портов. Если же Path Test не выполняется, то станция остается отс оединенной от кольца.

Функции управления, основанные на передаче кадров

Эта часть функций SMT, называемая FBM (Frame Based Management) является наиболее высокоуровневой, так как для ее работы требуется, чтобы кольцо находилось в работоспособном состоянии и могло передавать между станциями кадры. Спецификация FBM опреде ляет большое количество типов кадров, которыми обмениваются станции:

  • Кадры информации о соседстве (Neighborhood Information Frames, NIF) позволяют станции выяснить адреса ее предшествующего и последующего соседей, выяснить наличие дублированных адресов, а также проверить работоспособность своего МАС-узла при отсутствии другого трафика. Информация об адресах соседей может быть собрана управляющей станцией для построения логической карты кольца.
  • Кадры информации о статусе (Station Information Frames, SIF) используются станцией для передачи запроса о конфигурации и операционных параметрах другой станции. С помощью кадров SIF запрашиваются и передаются, например, данные о состоянии станции, зна чении счетчика кадров, приоритетах кадров, идентификаторе производителя.
  • Кадры отчета о статусе (Station Report Frames, SRF) позволяют станции периодически посылать по кольцу информацию о своем состоянии, которая может быть интересна станции управления кольцом. Это может быть, например, информация об изменении состояния ст анции, о нежелательных соединениях, о слишком высокой интенсивности ошибочных кадров.
  • Кадры управления параметрами (Parameter Management Frames, PMF) используются станцией для чтения или записи значений параметров базы данных управляющей информации SMT MIB.
  • Эхо-кадры (Echo Frames, ECF) позволяют станции проверить связь с любой станцией кольца.

Кадр SMT имеет собственный заголовок достаточно сложного формата, который вкладывается в информационное поле MAC кадра. За заголовком следует информационное поле SMT, которое содержит данные о нескольких параметрах станции. Каждый параметр описывается тре мя полями - полем типа параметра, полем длины параметра и полем значения параметра.

С помощью кадров PMF управляющая станция может получить доступ к значению параметров, хранящихся в базе данных управляющей информации станции - Management Information Base, MIB.

Спецификация SMT определяет состав объектов SMT MIB и их структуризацию. База SMT MIB состоит из 6 поддеревьев (рисунок 2.29). Поддерево 5 зарезервировано на будущее.

Рис. 2.29. Структура базы управляющей информации SMT MIB

Сообщество Internet разработало стандарт на базу управляющей информации MIB для сетей FDDI. Стандарт RFC 1285 определяет объекты, которые нужны для управления станциями FDDI по протоколу SNMP. База Internet FDDI MIB является поддеревом ветви Transmission базы MIB-II.

Объекты, определенные в RFC 1285, идентичны объектам SMT MIB. Однако, имена объектов и их синтаксис отличаются от спецификации SMT MIB. Эти отличия должны учитываться производителями оборудования и программного обеспечения управления. Обычно совместимость этих двух спецификаций достигается за счет встроенных в оборудование агентов-посредников FDDI/SNMP, а также за счет функций трансляции спецификаций в системах управления сетями.

На рисунке 2.30 приведена структура базы FDDI MIB по спецификации RFC 1285.

Рис. 2.30. Структура базы FDDI MIB по спецификации RFC 1285

В каких случаях рекомендуется использовать технологию FDDI

Особенностью технологии FDDI является сочетание нескольких очень важных для локальных сетей свойств:

  • высокая степень отказоустойчивости;
  • способность покрывать значительные территории, вплоть до территорий крупных городов;
  • высокая скорость обмена данными;
  • возможность поддержки синхронного мультимедийного трафика;
  • гибкий механизм распределения пропускной способности кольца между станциями;
  • возможность работы при коэффициенте загрузки кольца близком к единице;
  • возможность легкой трансляции трафика FDDI в трафики таких популярных протоколов как Ethernet и Token Ring за счет совместимости форматов адресов станций и использования общего подуровня LLC.

Пока FDDI - это единственная технология, которой удалось объединить все перечисленные свойства. В других технологиях эти свойства также встречаются, но не в совокупности. Так, технология Fast Ethernet также обладает скоростью передачи данных 100 Мб/с, но она не позволяет восстанавливать работу сети после однократного обрыва кабеля и не дает возможности работать при большом коэффициенте загрузки сети.

За уникальное сочетание свойств приходится платить - технология FDDI является сегодня самой дорогой 100 Мб технологией. Поэтому ее основные области применения - это магистрали кампусов и зданий, а также подключение корпоративных серверов. В этих случаях з атраты оказываются обоснованными - магистраль сети должна быть отказоустойчивой и быстрой, то же относится к серверу, построенному на базе дорогой мультипроцессорной платформы и обслуживающему сотни пользователей. Проект перевода сети университетского кам пуса на технологию Fast Ethernet, разработанный компанией 3Com и приведенный в разделе 1.9, очень характерен. Специалисты 3Com не предлагают отказываться от технологии FDDI на магистрали кампуса, во всяком случае они говорят о возможности перехода от FDDI к АТМ только на завершающих стадиях проекта модернизации, лет через 5 - 8.

Многие современные корпоративные сети построены с использованием технологии FDDI на магистрали в сочетании с технологиями Ethernet, Fast Ethernet и Token Ring в сетях этажей и отделов. Группа центральных серверов также обычно подключается к магистральному кольцу FDDI напрямую, с помощью сетевых адаптеров FDDI.

В связи с появлением более дешевых, чем FDDI 100 Мб технологий, таких как Fast Ethernet и 100VG-AnyLAN, технология FDDI, очевидно, не найдет широкого применения при подключении рабочих станций и создании небольших локальных сетей, даже при увеличении быст родействия этих станций и наличии в сетях мультимедийной информации.

Обзор оборудования, поддерживающего FDDI

В связи с тем, что технология FDDI уже давно утвердилась на рынке, существует большой выбор продуктов от различных производителей для каждого типа коммуникационного оборудования, используемого для построения локальных сетей - сетевых адаптеров, концентрат оров, коммутаторов и маршрутизаторов.

Сетевые адаптеры FDDI

Сетевые адаптеры FDDI отличаются типом подключения - двойное или одиночное, а также поддерживаемой средой передачи данных - оптволокно или неэкранированная витая пара категории 5. Стоимость сетевых адаптеров с двойным подключением, рассчитанных на оптовол окно колеблется в районе $1500 долларов, а сетевые адаптеры с одиночным подключением для витой пары стоят около $1000.

Концентраторы FDDI

Концентраторы FDDI выпускаются как в отдельных конструктивах с фиксированным количеством портов, так и в виде модулей для корпоративных концентраторов на основе шасси, таких как System 5000 компании Bay Networks или LANplex 6000 компании 3Com.

Средняя стоимость за порт концентратора FDDI составляла в 1996 году по данным Dell'Oro Group $835.

Концентратор FDDI 2914-04 компании Bay Networks

Модель 2914-04 - это концентратор FDDI, выполненный в отдельном корпусе и имеющий 14 портов. Все порты поддерживают многомодовый оптоволоконный кабель 50/125 или 62.5/125 мкм.

12 портов сконфигурированы как порты типа M для соединения со станциями с одиночным подключением, а два порта являются портами А и В для подключения концентратора к двойному кольцу. Порты А и В могут быть также сконфигурированы как М-порты, тогда концентр атор может объединять до 14 станций типа SAS.

Концентратор имеет два МАС-узла - первичный и локальный. Локальный используется для поддержки процедуры плавного включения станций в кольцо, не требующей его реинициализации.

Модуль концентратора FDDI для коммутатора LANplex 6000 компании 3Com

Данный модуль устанавливается в любой слот шасси LANplex 6000. Модуль выпускается в двух исполнениях - на 6 портов для многомодового оптоволоконного кабеля, или на 12 портов неэкранированной витой пары категории 5. Каждый порт может быть сконфигурирован к ак порт М для поддержки станций SAS или как порт А или В для поддержки станций DAS.

Модуль поддерживает спецификацию SMT 7.3 управление станцией, а также позволяет управлять им по протоколу SNMP, так как в него встроен агент SNMP/SMT proxy.

Коммутаторы FDDI

Коммутаторы FDDI делятся на два класса - коммутаторы с одним коммутируемым портом FDDI (или одним внутренним сегментом FDDI) и коммутаторы с несколькими коммутируемыми портами FDDI.

Коммутаторы первого типа появились гораздо раньше коммутаторов второго типа. В этих коммутаторах имеется несколько коммутируемых портов Ethernet, трафик которых может также направляться в магистральное кольцо FDDI, которое является либо внешним, либо внут ренним кольцом коммутатора. Передача кадров между сетями Ethernet и FDDI требует выполнения операции трансляции форматов кадров, что несколько замедляет работу такого коммутатора по сравнению с коммутатором, у которого один высокоскоростной порт - это пор т Fast Ethernet. Задержка коммутации Ethernet-FDDI может составлять 150 - 170 мкс, в то время как коммутаторы Ethernet - Fast Ethernet обеспечивают передачу кадров с задержкой в 10 - 40 мкс. Стоимость за порт коммутаторов Ethernet - FDDI с одним портом FD DI не очень отличается от стоимости за порт коммутаторов Ethernet, особенно при большом количестве портов Ethernet. Это происходит потому, что стоимость самого скоростного порта не слишком увеличивает общую стоимость, а требуемая общая производительность коммутатора при добавлении одного скоростного порта также возрастает не значительно, так как в этом случае нет коммутации между скоростными портами.

Коммутаторы второго типа, которые имеют несколько коммутируемых портов FDDI и, соответственно, выполняют коммутацию FDDI-FDDI, стоят существенно дороже. Средняя стоимость такого коммутатора за один порт составила в 1996 году по данным Dell'Oro Group около $4000. Коммутаторы этого типа появились недавно, так как потребность в коммутации высокоскоростных сегментов не была достаточно острой еще несколько лет назад, и большинство предприятий удовлетворялись подключением всех сегментов рабочих групп, отделов и ли этажей к единственному кольцу FDDI.

Коммутатор DECswitch 900EF компании Digital Equipment является типичным представителем коммутатора Ethernet-FDDI. Он выпускается как автономное устройство, либо как модуль для устройства DEChub 900 Multiswitch. Модель с 6 коммутируемыми портами Eth ernet и одним портом FDDI стоит $8000.

Модуль FDDI Switching Module (FSM) коммутатора LANplex 6000 представляет собой коммутатор FDDI-FDDI с двумя портами для подключения по схеме DAS. Модуль FSM подключается к внутренней протокольно-независимой высокоскоростной шине HSI (High Speed Int erface) коммутатора LANplex 6000, производительность которой в 13 Гб/с достаточна для коммутации 22 портов FDDI.

Пример построения сети по технологии FDDI

В качестве примера рассмотрим проект корпоративной сети АО "ЛУКойл-Кога-
лымнефтегаз" и "Нефтекомбанка", выполненный интеграционной российской компанией IBS Network Solutions (рисунок 2.31).

Рис. 2.31. Сеть АО "ЛУКойл-Когалымнефтегаз", построенная с использованием технологии FDDI

АО "ЛУКойл-Когалымнефтегаз" представляет собой одно из крупнейших в России объединений, действующих на рынке нефтегазодобычи. В структуру объединения входит "Нефтекомбанк". Подавляющее число административных зданий объединения расположены на относительно небольшой территории (диаметром порядка 7 км) города Когалым.

К моменту начала осуществления проекта в некоторых зданиях работали локальные сети с общим числом компьютеров около 700, но соединения между сетями зданий отсутствовали.

В предложенном проекте семь зданий АО на территории города Когалым объединяются на основе оптоволоконного кабеля и технологии FDDI. В каждом здании установлен центральный для сети здания коммутатор LANplex 2500, позволяющий осуществлять коммутацию двух се тей FDDI или коммутацию одной сети FDDI с 8-ю сегментами Ethernet. При подключении к кольцу FDDI используется подключение типа DAС на многомодовом или одномодовом оптоволоконном кабеле.

В предложенном проекте используется два магистральных кольца FDDI, объединенные коммутатором LANplex.

К каждому из магистральных колец подключается несколько сетей зданий с помощью своих коммутаторов LANplex. Подключение по схеме DAC обеспечивает надежное функционирование магистральных колец, изоляция сетей зданий на физическом уровне осуществляется с пом ощью оптических обходных переключателей Optical Bypass Switch.

Сети этажей и функциональных подразделений зданий используют технологию Ethernet. Сегменты Ethernet подключаются к коммутатору LANplex через порты его коммутирующего модуля Ethernet. Некоторые удаленные небольшие сети подключаются к магистральной сети не по технологии FDDI, а по технологии 10Base-FL, используя оптоволоконные повторители FMS Optical Repeater.

Все коммуникационное оборудование сети управляется с помощью системы управления Transcend Enterprise Manager компании 3Сом.

Предыдущая глава | Оглавление | Следующая глава

Back Home E-mail

Copyright © CIT


Технология 100VG-AnyLAN

Общая характеристика технологии 100VG-AnyLAN

В качестве альтернативы технологии Fast Ethernet, фирмы AT&T и HP выдвинули проект новой технологии со скоростью передачи данных 100 Мб/с - 100Base-VG. В этом проекте было предложено усовершенствовать метод доступа с учетом потребности мультиме дийных приложений, при этом сохранить совместимость формата пакета с форматом пакета сетей 802.3. В сентябре 1993 года по инициативе фирм IBM и HP был образован комитет IEEE 802.12, который занялся стандартизацией новой технологии. Проект был расширен за счет поддержки в одной сети кадров не только формата Ethernet, но и формата Token Ring. В результате новая технология получила название 100VG-AnyLAN, то есть технология для любых сетей (Any LAN - любые сети), имея в виду, что в локальных сетях техн ологии Ethernet и Token Ring используются в подавляющем количестве узлов.

Летом 1995 года технология 100VG-AnyLAN получила статус стандарта IEEE 802.12.

В технологии 100VG-AnyLAN определены новый метод доступа Demand Priority и новая схема квартетного кодирования Quartet Coding, использующая избыточный код 5В/6В.

Метод доступа Demand Priority основан на передаче концентратору функций арбитра, решающего проблему доступа к разделяемой среде. Метод Demand Priority повышает коэффициент использования пропускной способности сети за счет введения простого, детерми нированного метода разделения общей среды, использующего два уровня приоритетов: низкий - для обычных приложений и высокий - для мультимедийных.

Технология 100VG-AnyLAN имеет меньшую популярность среди производителей коммуникационного оборудования, чем конкурирующее предложение - технология Fast Ethernet. Компании, которые не поддерживают технологию 100VG-AnyLAN, объясняют это тем, что для большин ства сегодняшних приложений и сетей достаточно возможностей технологии Fast Ethernet, которая не так заметно отличается от привычной большинству пользователей технологии Ethernet. В более далекой перспективе эти производители предлагают использовать для м ультимедийных приложений технологию АТМ, а не 100VG-AnyLAN.

Тем не менее, число сторонников технологии 100VG-AnyLAN растет и насчитывает около 30 компаний. Среди них находятся не только копании Hewlett-Packard и IBM, но и такие лидеры как Cisco Systems, Cabletron, D-Link и другие. Все эти компании поддерживают обе конкурирующие технологии в своих продуктах, выпуская модули с портами как Fast Ethernet, так и 100VG-AnyLAN.

Структура сети 100VG-AnyLAN

Сеть 100VG-AnyLAN всегда включает центральный концентратор, называемый концентратором уровня 1 или корневым концентратором (рисунок 3.1).

Корневой концентратор имеет связи с каждым узлом сети, образуя топологию типа звезда. Этот концентратор представляет собой интеллектуальный центральный контроллер, который управляет доступом к сети, постоянно выполняя цикл "кругового" сканирован ия своих портов и проверяя наличие запросов на передачу кадров от присоединенных к ним узлов. Концентратор принимает кадр от узла, выдавшего запрос, и передает его только через тот порт, к которому присоединен узел c адресjv, совпадающиv с адресом назначе ния, указанным в кадре.

Рис. 3.1 . Структура сети 100VG-AnyLAN

Каждый концентратор может быть сконфигурирован на поддержку либо кадров 802.3 Ethernet, либо кадров 802.5 Token Ring. Все концентраторы, расположенные в одном и том же логическом сегменте (не разделенном мостами, коммутаторами или маршрутизаторами), должн ы быть сконфигурированы на поддержку кадров одного типа. Для соединения сетей 100VG-AnyLAN, использующих разные форматы кадров 802.3, нужен мост, коммутатор или маршрутизатор. Аналогичное устройство требуется и в том случае, когда сеть 100VG-AnyLAN должна быть соединена с сетью FDDI или АТМ.

Каждый концентратор имеет один "восходящий" (up-link) порт и N "нисходящих" портов (down-link), как это показано на рисунке 3.2.

Рис. 3.2. Круговой опрос портов концентраторами сети 100VG-AnyLAN

Восходящий порт работает как порт узла, но он зарезервирован для присоединения в качестве узла к концентратору более высокого уровня. Нисходящие порты служат для присоединения узлов, в том числе и концентраторов нижнего уровня. Каждый порт концентратора м ожет быть сконфигурирован для работы в нормальном режиме или в режиме монитора. Порт, сконфигурированный для работы в нормальном режиме, передает только те кадры, которые предназначены узлу, подключенному к данному порту. Порт, сконфигурированный для рабо ты в режиме монитора, передает все кадры, обрабатываемые концентратором. Такой порт может использоваться для подключения анализатора протоколов.

Узел представляет собой компьютер или коммуникационное устройство технологии 100VG-AnyLAN - мост, коммутатор, маршрутизатор или концентратор. Концентраторы, подключаемые как узлы, называются концентраторами 2-го и 3-го уровней. Всего разрешается образовыв ать до трех уровней иерархии концентраторов.

Связь, соединяющая концентратор и узел, может быть образована либо 4 парами неэкранированной витой пары категорий 3, 4 или 5 (4-UTP Cat 3, 4, 5), либо 2 парами неэкранированной витой пары категории 5 (2-UTP Cat 5), либо 2 парами экранированной витой пары типа 1 (2-STP Type 1), либо 2 парами многомодового оптоволоконного кабеля.

Варианты кабельной системы могут использоваться любые, но ниже будет рассмотрен вариант 4-UTP, который был разработан первым и получил наибольшее распространение.

В заключение раздела приведем таблицу, составленную компанией Hewlett-Packard, в которой приводятся результаты сравнения этой технологии с технологиями 10Base-T и 100Base-T.
Характеристика | 10Base-T | 100VG-AnyLAN | 100Base-T
Топология
Максимальный
диаметр сети 		2500 м 8000 м412 м
Каскадирование
концентраторов		Да; 3 уровняДа; 5 уровнейДва концентратора максимум
Кабельная система
UTP Cat 3,4 | 100 м | 100 м | 100 м
UTP Cat 5 | 150 м | 200 м | 100 м
STP Type 1 | 100 м | 100 м | 100 м
Оптоволокно | 2000 м | 2000 м | 412 м
Производительность
При длине сети 100 м | 80% (теоретическая) | 95% (продемонстрированная) | 80% (теоретическая)
При длине сети 2500 м | 80% (теоретическая) | 80% (продемонстрированная) | Не поддерживаетс
Технология
Кадры IEEE 802.3 | Да | Да | Да
Кадры 802.5 | Нет | Да | Нет
Метод доступа | CSMA/CD | Demand Priority | CSMA/CD + подуровень согласования (Reconciliation sublayer)

Стек протоколов технологии 100VG-AnyLAN

Структура стека протоколов технологии 100VG-AnyLAN согласуется с архитектурными моделями OSI/ISO и IEEE, в которых канальный уровень разделен на подуровни. Как видно из рисунка 3.3, стек протоколов технологии 100VG-AnyLAN состоит из подуровня доступа к ср еде (Media Access Control, MAC), подуровня, независящего от физической среды (Physical Media Independent, PMI) и подуровня, зависящего от физической среды (Physical Media Dependent, PMD).

Рис. 3.3. Структура стека протоколов технологии 100VG-AnyLAN

Функции уровня MAC

Функции уровня МАС включают реализацию протокола доступа Demand Priority, подготовки линии связи и формирования кадра соответствующего формата.

Метод Demand Priority (приоритетный доступ по требованию) основан на том, что узел, которому нужно передать кадр по сети, передает запрос (требование) на выполнение этой операции концентратору. Каждый запрос может иметь либо низкий, либо высокий пр иоритеты. Высокий приоритет отводиться для трафика чувствительных к задержкам мультимедийных приложений.

Высокоприоритетные запросы всегда обслуживаются раньше низкоприоритетных. Требуемый уровень приоритета кадра устанавливается протоколами верхних уровней, не входящими в технологию 100VG-AnyLAN, например, Real Audio, и передается для отработки уровню МАС.

Как показано на рисунке 3.2, концентратор уровня 1 постоянно сканирует запросы узлов, используя алгоритм кругового опроса (round-robin). Это сканирование позволяет концентратору определить, какие узлы требуют передачи кадров через сеть и каковы их приорит еты.

В течение одного цикла кругового сканирования каждому узлу разрешается передать один кадр данных через сеть. Концентраторы, присоединенные как узлы к концентраторам верхних уровней иерархии, также выполняют свои циклы сканирования и передают запрос на пер едачу кадров концентратору. Концентратор нижнего уровня с N портами имеет право передать N кадров в течение одного цикла опроса.

Каждый концентратор ведет отдельные очереди для низкоприоритетных и высокоприоритетных запросов. Низкоприоритетные запросы обслуживаются только до тех пор, пока не получен высокоприоритетный запрос. В этом случае текущая передача низкоприоритетного кадра завершается и обрабатывается высокоприоритетный запрос. Перед возвратом к обслуживанию низкоприоритетных кадров должны быть обслужены все высокоприоритетные запросы. Для того, чтобы гарантировать доступ для низкоприоритетных запросов в периоды высокой инт енсивности поступления высокоприоритетных запросов, вводится порог ожидания запроса. Если у какого-либо низкоприоритетного запроса время ожидания превышает этот порог, то ему присваивается высокий приоритет.

На рисунке 3.2 показан пример цикла кругового опроса. Сначала предположим, что все порты передали запросы нормального приоритета и что в начальный момент времени корневой концентратор начал круговой опрос. Порядок обслуживания портов будет следующим: 1-1 (уровень 1 - порт 1), 2 -1, 2-3, 2-N, 1-3, 1-N.

Теперь предположим, что узлы 1-1, 2-3 и 1-3 выставили высокоприоритетные запросы. В этом случае порядок обслуживания будет таким: 1-1, 2-3, 1-3, 2-1, 2-N, 1-N.

Процедура подготовки линии Link Training "обучает" внутренние схемы концентратора и узла приему и передаче данных, а также проверяет работоспособность линии, соединяющей концентратор и узел.

Во время подготовки линии концентратор и узел обмениваются серией специальных тестовых кадров. Данная процедура включает функциональный тест кабеля, дающий возможность убедиться в том, что кабель правильно соединяет контакты разъемов и что информация може т быть корректно передана между концентратором и узлом.

Процедура подготовки также позволяет концентратору автоматически узнать информацию об узлах, подключенных к каждому порту. Кадры, получаемые концентратором от узла во время подготовки, содержат данные о типе устройства (конечный узел, концентратор, мост, маршрутизатор, анализатор протокола и т.п.), режиме работы (нормальный или монитор), адрес узла, присоединенного к данному порту.

Процедура подготовки инициируется узлом, когда узел или концентратор впервые включаются, или при первом присоединении узла к концентратору. Узел или концентратор могут потребовать выполнения процедуры подготовки при обнаружении ошибочной ситуации.

Уровень МАС получает кадр от уровня LLC и добавляет к нему адрес узла-источника, дополняет поле данных байтами-заполнителями до минимально допустимого размера, если это требуется, а затем вычисляет контрольную сумму и помещает ее в соответствующее поле. П осле этого кадр передается на физический уровень.

Функции уровня PMI

Функции, не зависящие от физической среды, представленные на рисунке 3.4, включают квартетную канальную шифрацию, кодирование 5B/6B, добавление к кадру преамбулы, начального и конечного ограничителей и передачу кадра на уровень PMD.

Рис. 3.4. Функции уровней PMI и PMD

Процесс квартетного распределения по каналам состоит в последовательном делении байтов МАС-кадра на порции данных по 5 бит (квинтеты), а также в последовательном распределении этих порций между четырьмя каналами, как это показано на рисунке 3.5.

Каждый из 4-х каналов представляет собой одну витую пару: канал 0 - пару, образованную контактами 1 и 2, канал 1 - пару 3 - 6, канал 2 - пару 4 - 5, канал 3 - пару 7 - 8. Двухпарные спецификации физического уровня PMD используют затем схему мультиплексиро вания, преобразующую 4 канала в 2 или 1.

Рис. 3.5. Распределение квинтетов по 4-м каналам

Шифрация данных состоит в случайном "перемешивании" квинтетов данных с целью исключения комбинаций из повторяющихся единиц или нулей. Перемешивание производится с помощью специальных устройств - скремблеров. Случайные наборы цифр уменьшают излучение радио волн и взаимные наводки в кабеле.

Кодирование по схеме 5B/6B - это процесс отображения "перемешанных" квинтетов в заранее определенные 6-битовые коды. Этот процесс создает сбалансированные коды, содержащие равное количество единиц и нулей, что обеспечивает гарантированную синхронизацию пр иемника при изменениях входного сигнала.

Кодирование 5B/6B обеспечивает также контроль за ошибками при передаче, так как некорректные квинтеты, содержащие больше трех единиц или больше трех нулей, легко обнаружить.

На рисунке 3.6 приведен пример квинтетов данных, зашифрованных и преобразованных в символы 5B/6B. Поскольку существует только 16 сбалансированных символов, 32 комбинации, содержащиеся в квинтете, используют для своего представления два 6-ти битных символа , используемых по очереди для соблюдения баланса постоянного тока.

Рис. 3.6. Пример шифрации и кодирования квинтетов

Преамбула, начальный и конечный ограничители добавляются в каждом канале для корректной передачи данных через сеть.

Функции уровня PMD

Функции зависимого от физической среды уровня PMD включают: мультиплексирование каналов (только для 2-х витых пар или оптоволокна), копирование NRZ, операции передачи сигналов по среде и контроль статуса физической связи.

Технология 100VG-AnyLAN поддерживает следующие типы физической среды:

  • 4-парную неэкранированную витую пару;
  • 2-парную неэкранированную витую пару;
  • 2-парную экранированную витую пару;
  • одномодовый или многомодовый оптоволоконный кабель.

Далее будут рассмотрены детали спецификации PMD для 4-парной неэкранированной витой пары.

Рисунок 3.7 иллюстрирует применения NRZ кодирования, использующего для представления единиц потенциал высокого уровня, а для представления нулей - потенциал низкого уровня.

Рис. 3.7. NRZ кодирование

Спецификация 4UTP, использующая 4-парную неэкранированную витую пару, использует тактовый генератор с частотой 30 МГц для передачи данных со скоростью 30 Мб/с по каждому из четырех каналов, что в сумме дает 120 Мб/c кодированных данных. Приемник получает кодированные данные со скоростью 30 Мб/с по каждому каналу и преобразует их в поток исходных данных со скоростью 25 Мб/с, что в результате дает пропускную способность в 100 Мб/с.

Использованный метод представления данных в кабеле позволяет технологии 100VG-AnyLAN работать на голосовом кабеле (Voice-Grade) категории 3. Максимальная частота результирующего сигнала на кабеле не превышает 15 МГц, так как метод NRZ очень эффективен в о тношении спектра сигналов. При тактовой частоте в 30 МГц частота 15 МГц генерируется только при передаче кодов 10101010, что является для спектра результирующего сигнала наихудшим случаем. При передаче других кодов частота сигнала будет ниже 15 МГц.

Операции передачи данных на 4-парном кабеле используют как полнодуплексный, так и полудуплексный режимы (рисунок 3.8).

Полнодуплексные операции используются для одновременной передачи в двух направлениях - от узла к концентратору и от концентратора к узлу - сигнальной информации о состоянии линии. Сигнальная информация от концентратора идет по парам 1-2 и 3-6, а сигнальна я информация от узла идет по парам 4-5 и 7-8.

Рис. 3.8. Полнодуплексные и полудуплексные операции

Полудуплексные операции используются для передачи данных от концентратора узлу и от узла концентратору по всем четырем парам.

Сигнализация о статусе связи, осуществляемая в полнодуплексном режиме, использует два низкочастотных сигнала, обозначаемые как тон 1 (Tone 1) и тон 2 (Tone 2).

Тон 1 генерируется путем передачи с частотой 30 МГц по очереди кодов, состоящих из 16 единиц, и кодов, состоящих из 16 нулей. Результирующий сигнал имеет частоту примерно 0.9375 МГц.

Тон 2 генерируется путем передачи с частотой 30 МГц по очереди кодов, состоящих из 8 единиц, и кодов, состоящих из 8 нулей. Результирующий сигнал имеет частоту примерно 1.875 МГц.

Взаимодействие между концентратором и узлом происходит путем параллельной передачи по двум парам комбинации из указанных двух тонов.

В следующей таблице приведены значения возможных 4-х комбинаций тонов.
Комбинация тонов | Значение при приеме узлом | Значение при приеме концентратором
1 - 1 | Простой (Idle) | Простой (Idle)
1 - 2 | Поступление кадра | Запрос на передачу кадра с нормальным приоритетом
2 -1 | Зарезервировано | Запрос на передачу кадра с высоким приоритетом
2 - 2 | Запрос на инициализацию процедуры подготовки линии | Запрос на инициализацию процедуры подготовки линии

Состояние простоя означает, что концентратор или узел не имеют кадров, ожидающих передачи.

Состояние "поступление кадра" означает, что на данный порт может быть передан кадр. Узел должен прекратить передачу сигнальных тонов по каналам 2 и 3 для того, чтобы быть готовым принять кадр.

Тестирование кабелей для установки их в сетях 100VG-AnyLAN

Спецификация 4-UTP 100VG-AnyLAN использует для тестирования кабеля те же параметры, что и технологии 10Base-T и Token Ring. Кроме того, кабель должен удовлетворять дополнительным требованиям - тестовую проверку должны пройти все 4 пары на частотах до 15 М Гц.

В следующей таблице приведены параметры, по которым должен проверяться кабель для работы по спецификации 4-UTP 100VG-AnyLAN.
Частота | 5 МГц | 10 МГц | 15 МГц
Максимальное затухание | 11.5 dB | 11.5 dB | 13.5 dB
Импеданс | от 85 до 115 Ом | от 85 до 115 Ом | от 85 до 115 Ом
Перекрестные наводки "пара-пара" | 30.5 dB | 26.0 dB | 22.5 dB
Перекрестные наводки на ближнем конце пары (NEXT) | 27.5 dB | 23.0 dB | 19.5 dB

Пример работы сети 100VG-AnyLAN при передаче кадров данных

Рассмотрим последовательность событий в сети 100VG-AnyLAN при передаче кадра данных от одной станции другой через концентратор.

Будем считать, что узел посылает в сеть один кадр данных с нормальным приоритетом. На рисунке 3.9 приведены 9 этапов этого процесса.

Рис. 3.9. Этапы передачи кадра данных через сеть 100VG-AnyLAN

Процесс начинается с получения МАС-уровнем конечного узла кадра данных от уровня LLC. После этого МАС-уровень добавляет к кадру адрес источника и дополняет поле данных, если сеть поддерживает формат кадров 802.3 и поле данных кадра LLC оказалось меньше 46 байт.

На этапе 1 узел PC1 посылает в концентратор запрос нормального приоритета: тон 1 по каналу 2 и тон 2 по каналу 3.

Во время цикла кругового опроса концентратор выбирает запрос узла PC1 на обслуживание, в результате чего он прекращает генерацию комбинации сигнальных тонов "Про-
стой" по каналам 0 и 1, очищая линию для передачи кадра по всем четырем каналам.

Затем концентратор предупреждает всех потенциальных получателей - узлы PC2 - PCn сети - о том, что им может быть направлен кадр данных. Для этого он посылает им сообщение "Поступление кадра" в форме тона 1 на канале 0 и тона 2 на канале 2 (этап 2).

Узлы - потенциальные получатели кадра прекращают посылку сигнальных тонов по каналам 2 и 3, очищая линию связи для передачи по всем четырем каналам кадра данных.

Тем временем узел-источник кадра обнаруживает, что линия свободна и передает кадр с уровня МАС на уровень PMI для подготовки его к передаче по кабелю.

Уровень PMI распределяет данные между четырьмя каналами, шифрует квинтеты данных и кодирует квинтеты в 60-битный код 5В/6B. Добавляются преамбула, стартовый и конечный ограничители по каждому каналу.

Уровень PMD начинает передавать кадр концентратору, используя NRZ кодирование (этап 3).

По мере поступления данных кадра концентратор декодирует адрес назначения (этап 4).

Затем кадр передается через соответствующий порт тому узлу, который имеет адрес, совпадающий с адресом назначения кадра (этап 5). В это же время концентратор перестает посылать сигнал "Поступление кадра" и начинает генерировать сигналы "Простой" всем оста льным узлам (этап 6). Эти узлы теперь могут посылать запросы на передачу своих кадров концентратору.

Обзор оборудования, поддерживающего технологию 100VG-AnyLAN

В оборудование, поддерживающее технологию 100VG-AnyLAN, входит весь спектр коммуникационного оборудования, применяемого для построения локальных сетей: сетевые адаптеры, концентраторы, коммутаторы и маршрутизаторы.

Основу этого оборудования, безусловно, составляет оборудование компании Hewlett-Packard, которая является основной движущей силой, развивающей и пропагандирующей эту технологию. Кроме Hewlett-Packard, существует уже достаточно обширный список компаний, ко торые выпускают отдельные виды устройств, например сетевые адаптеры или модули для маршрутизаторов, для технологии 100VG-AnyLAN.

Сетевые адаптеры 10/100VG PC LAN компании Hewlett-Packard

Переключаемые адаптеры НP 10/100 VG PC LAN для платформ ISA, EISA и PCI могут поддерживать технологии 10Base-T или 100 VG. Переход с 10 Мб/с на 100 Мб/с происходит легко - нужно переместить сетевой кабель из одного коннектора в другой и перезагрузить ПК. Не требуется менять драйвер и конфигурацию.

Адаптеры обладают к тому же большой пакетной буферной памятью: 128 Кб EISA, 64 Кб для ISA, 128 Кб для PCI. Они комплектуются полными программными средствами для конфигурирования и диагностики, устраняющими необходимость использования переключателей.

Адаптеры HP 10/100VG совместимы с основными сетевыми операционными системами и имеют полную поддержку драйверов для Novell NetWare, Windows NT, Windows for Workgroups, SCO Unix и UnixWare.

Примерная стоимость - $190.

Кроме сетевых адаптеров Hewlett-Packard, хорошо себя показали в испытаниях, проведенных тестовой лабораторией журнала Data Communications (Data Communications, March 1996, Vol. 25, No. 3), сетевые адаптеры компаний Racor Computer и Compex. Модель ThunderL AN M8148/M8149-020 компании Racor была признана лучшей в классе адаптеров для серверов, показав очень хорошее сочетание высокой производительности с небольшим коэффициентом использования центрального процессора. Эти показатели составили 56 Мб/с полезной п роизводительности при передаче файлов кадрами различной длины и 65% использования центрального процессора. В классе сетевых адаптеров для клиентских машин первенствовала карта Enet100VG4/PCI компании Compex. Сетевые адаптеры 100VG компании Hewlett-Packard также принимали участие в тестировании и показали неплохие результаты, но по производительности все же несколько отстали от победителей.

Концентратор 100VG Hub-15 компании Hewlett-Packard

Концентратор 100VG Hub-15 является наиболее широко применяемым устройством для построения сегментов в технологии 100VG-AnyLAN.

Этот концентратор имеет 15 портов RJ-45 для непосредственного подключения рабочих станций 100VG с помощью кабеля на неэкранированной витой паре.

Концентратор реализует передачу кадров Ethernet между своими 15 портами на основе протокола Demand Priority, обеспечивая около 96% пропускной способности 100 Мб/с для передачи полезной информации.

Для связи с концентратором верхнего уровня 100VG Hub-15 имеет специальный порт Uplink, с помощью которого концентраторы 100VG можно каскадировать.

Кроме этого, концентратор снабжен двумя портами (In и Out) для организации общей для стека шины управления.

По аналогии с 12/24/48-портовыми концентраторами НРAdvanceStack 10Base-T, 100VG Hub-15 обладает слотом расширения, который обеспечивает следующие возможности:

  • установку в дополнительный слот модуля, реализующего управление по протоколу SNMP;
  • реализацию функций HP EASE (Embedded Advanced Sampling Environment);
  • установку модулей мостов и маршрутизаторов.

Концентратор можно приобрести с установленным в слот расширения модулем SNMP-управления или без него. Установленный в любой из 16 концентраторов 100VG стека модуль НР AdvanceStack 100VG SNMP/Bridge даст возможность управлять по протоколу SNMP всеми концен траторами стека.

Кроме того, модуль НР AdvanceStack 100VG SNMP/Bridge предоставляет возможность организовать мост между сегментом 100VG-AnyLAN и сегментом 10Base-T, построенном на концентраторах HP AdvanceStack или других концентраторах 10Base-T.

Управлять концентратором 100VG Hub-15 можно тремя способами:

  • Базовые средства управления: для сетей, которые не требуют SNMP-управления. Вместе с каждым концентратором НР AdvanceStack 100VG Hub-15 поставляется основанное на Windows программное обеспечение HP Stack Manager, которое управляет базовыми конфигураци ями, осуществляет мониторинг и устранение неполадок в стеке, оперативно отображая состояние устройства и позволяя быстро пересматривать, конфигурировать и диагностировать порты.
  • SNMP-управление: для более крупных сетей с более интенсивным трафиком. Чтобы получить дополнительные возможности управления, нужно просто добавить модуль HP AdvanceStack 100VG SNMP/Bridge и программное обеспечение HP OpenView InterConnect Manager. Так ая комбинация обеспечивает необходимые средства сетевого управления, подобные стандартному SNMP, универсальную и частные базы MIB, автоматическое отображение конфигурации сети, информирование о событиях и неисправностях, загрузку и выгрузку встроенных про грамм.
  • Расширенные средства управления: для сетей, которые требуют оптимальной производительности. В комбинации с такими приложениями, как Traffic Expert или Traffic Monitor, средства EASE, которые обеспечиваются при установке в любой концентратор стека моду ля HP AdvanceStack 100VG SNMP/Bridge, позволяют оптимизировать производительность сети посредством одного стека. При этом графически указываются потенциальные участки возникновения неполадок, идентифицируется, кто использует те или иные сетевые ресурсы, и показываются образцы трафика.

Примерная стоимость концентратора - $3000.

Коммутаторы и маршрутизаторы, поддерживающие 100VG-AnyLAN

Компания Hewlett-Packard выпускает коммутатор AdvanceStack 10/100 Switch 16, который имеет модульную конструкцию и поддерживает скорости обмена как 10 Мб/с, так и 100 Мб/с. Коммутатор имеет 16 портов 10Base-T и возможность для установки двух дополнительны х высокоскоростных интерфейсов 100Base-TX или 100VG. Все порты коммутируемые. Однопортовый модуль 100Base-TX стоит $1400, а двухпортовый модуль 100VG - $2000.

Среди ведущих производителей коммутаторов технологию 100VG-AnyLAN поддерживает также компания Cisco, выпустившая модули 100VG для своего мощного коммутатора Сatalyst 5000.

Компания Hewlett-Packard реализовала поддержку технологии 100VG-AnyLAN в своем корпоративном маршрутизаторе модели 650. Среди других производителей маршрутизаторов модули с интерфейсами 100VG-AnyLAN выпускают компании Cisco, Proteon и Newbridge.

Пример корпоративной сети на технологии 100VG-AnyLAN

В качестве примера применения технологии 100VG-AnyLAN для крупной корпоративной сети, рассмотрим предложение компании Hewlett-Packard по модернизации той же сети университетского кампуса, которую мы рассмотрели в разделе 1.9. В планы организаторов меропри ятия High-Speed LAN Shoot-Out III как раз и входило сравнение проектов, основанных на конкурирующих высокоскоростных технологиях, для одной и той же реальной крупной сети.

Предложение компании Hewlett-Packard иллюстрирует рисунок 3.10.

Интересно, что компания Hewlett-Packard, как и компания 3Com, решила оставить в качестве магистрали сети, охватывающей все здания кампуса, кольцо FDDI .

Основное внимание в проекте отводится сетям здания. Рабочие группы образуются на основе концентраторов 100VG Hub-15. В отличие от предложения 3Com, решившей централизовать основные серверы здания за счет их непосредственного подключения к коммутатору здан ия. В проекте Hewlett-Packard серверы оставлены там, где они и находились - в рабочих группах.

Каждое здание снабжается одним центральным коммутатором LAN Switch 16, способным коммутировать сегменты Ethernet, 10Base-T и сегменты 100VG. Устройства LAN Switch 16 используются для коммутации сетей этажей, а также для коммутации сегментов Ethernet, обра зованных 60 пользователями компьютеров Macintosh.

Для подключения сети здания к магистральному кольцу FDDI используется маршрутизатор модели 650 компании Hewlett-Packard с интерфейсом 100VG и FDDI.

Модернизацию сети предлагается провести за 5 этапов.

На первом этапе нужно провести тестирование всех четырех пар кабельной системы на соответствие требованиям 100VG. Затем эта технология внедряется в некоторых рабочих группах, там, где повышенная производительность нужна в первую очередь.

На втором этапе в здании устанавливается коммутатор AN Switch 16 и маршрутизатор 100VG/FDDI. Количество рабочих групп, перешедших на 100VG, также существенно увеличивается.

На третьем этапе все рабочие группы во всех зданиях переходят на технологию 100VG.

Четвертый этап состоит в мониторинге сетевого трафика с целью выявления сегментов, которые необходимо выделить для прямого подключения к коммутаторам. Возможно увеличение числа коммутаторов в некоторых зданиях.

Рис. 3.10. Применение технологии 100VG-AnyLAN в сети университетского кампуса

И, наконец, пятый этап, который возможен в более отдаленном будущем, может состоять в переходе от технологии FDDI на магистрали сети к гигабитным технологиям, к которым собирается присоединиться и вариант 1000VG, разрабатываемый в настоящее время.

Предыдущая глава | Оглавление | Следующая глава

Back Home E-mail

Copyright © CIT


Перспективы высокоскоростных технологий - переход на гигабитные скорости

Хотя переход на новые высокоскоростные технологии, такие как Fast Ethernet и 100VG-AnyLAN, начался не так давно, уже находятся в разработке два новых проекта - технология Gigabit Ethernet и Gigabit VG, предложенные соответственно Gigabit Ethernet Alliance и комитетом IEEE 802.12.

Интерес к технологиям для локальных сетей с гигабитными скоростями повысился в связи с двумя обстоятельствами - во-первых, успехом сравнительно недорогих (по сравнению с FDDI) технологий Fast Ethernet и 100VG-AnyLAN, во-вторых, со слишком большими труднос тями, испытываемыми технологией АТМ на пути к конечному пользователю.

Технология АТМ обладает многими привлекательными свойствами - масштабируемой скоростью передачи данных, доходящей до 10 Гб/с, отличной поддержкой мултимедийного трафика и возможностью работы как в локальных, так и в глобальных сетях. Однако, стоимость тех нологии АТМ и ее сложность не всегда оправданы. Вот для таких применений, в которых нужна в первую очередь высокая скорость обмена, а без других возможностей, предлагаемых АТМ, можно прожить, и предназначены активно разрабатываемые сегодня гигабитные вари анты Ethernet и VG.

За комитетом 802.12 стоит, естественно, компания Hewlett-Packard, сотрудница которой и возглавляет сегодня этот комитет. К энтузиастам перевода технологии VG на гигабитные скорости относятся также компании Compaq Computer, Texas Instrument и Motorola.

В Gigabit Ethernet Alliance входят наряду с другими компании Bay Networks, Cisco Systems и 3Com.

Обе группы намерены широко использовать достижения технологии Fibre Channel, уже работающей с гигабитными скоростями. Во всяком случае, Fibre Channel со своим методом кодирования 8B/10B фигурирует как один из вариантов физического уровня для оптоволоконно го кабеля.

Разрабатываемые предложения оставляют метод доступа в неизменном виде: CSMA/CD для технологии Gigabit Ethernet и Demand Priority для Gigabit VG.

В связи с ограничениями, накладываемыми методом CSMA/CD на длину кабеля, версия Gigabit Ethernet для разделяемой среды будет допускать длину связей до 25 метров на витой паре. В связи с такими серьезными ограничениями более популярны будут, очевидно, полн одуплексные версии гигабитного Ethernet'a, работающие только с коммутаторами и допускающие расстояние между узлом и коммутатором в 500 метров для многомодового кабеля и до 2 км для одномодового кабеля.

Появление первого проекта стандарта Gigabit Ethernet ожидается в начале 1997 года, а его окончательное принятие - вначале 1998 года.

Gigabit Ethernet Alliance предполагает, что стоимость одного порта концентратора Gigabit Ethernet в 1998 году составит от $920 до $1400, а стоимость одного порта коммутатора Gigabit Ethernet составит от $1850 до $2800.

Для технологии Gigabit VG предлагается реализовать скорость 500 Мб/с для витой пары и 1 Гб/с для оптоволокна. Предельные расстояния между узлами ожидаются следующие: для витой пары - 100 м, для многомодового оптоволокна - 500 м и для одномодового оптоволо кна - 2 км.

Предыдущая глава | Оглавление

Back Home E-mail

Copyright © CIT


Created using
htm2chm 3.0

Download it NOW!


Высокоскоростные технологии ЛВС

Если производительность сети перестает отвечать предъявляемым ей требованиям, то администратор сети может прибегнуть к различным приемам. Он может, например, изменить конфигурацию сети таким образом, чтобы структура сети более соответствовала структуре ин формационных потоков, или перейти к другой модели построения распределенных приложений, которая позволила бы уменьшить сетевой трафик, или заменить все мосты более скоростными коммутаторами. Но самым радикальным решением в такой ситуации является переход на более скоростную технологию. Если в сети используются традиционные технологии Ethernet или Token Ring, то переход на Fast Ethernet, FDDI или 100VG-AnyLAN позволит сразу в 10 раз увеличить пропускную способность каналов.

  1. Технология Fast Ethernet (IEEE 802.3u)
    • Fast Ethernet как развитие классического Ethernet'а
      • Рост требований к пропускной способности локальных сетей
      • Способы повышения пропускной способности сети
      • Создание стандарта Fast Ethernet
    • Метод доступа к среде CSMA/CD
      • Подуровень Logical Link Control (LLC)
      • Подуровень управления доступом к среде Media Access Control (MAC)
    • Форматы кадров
    • Спецификации физического уровня
      • Структура физического уровня и его связь с MAC-подуровнем
      • Интерфейс MII
        • Передача данных через MII
        • Сообщения об ошибках в MII
        • Управление конфигурацией в MII
      • Физический уровень 100Base-FX - многомодовое оптоволокно
        • Метод кодирования 4B/5B
        • Передача 5-битовых кодов по линии методом NRZI
      • Физический уровень 100Base-TХ - двухпарная витая пара
        • Auto-negotiation - автопереговоры по принятию режима работы порта
        • Полнодуплексный режим работы
      • Физический уровень 100Base-T4 - четырехпарная витая пара
    • Правила построения сегментов Fast Ethernet при использовании повторителей класса I и класса II
      • Ограничения длин сегментов DTE-DTE
      • Ограничения, связанные с соединениями с повторителями
    • Управление в сетях Fast Ethernet. Параметры протокола Ethernet, отслеживаемые агентами SNMP и RMON
    • В каких случаях рекомендуется использовать Fast Ethernet
      • Fast Ethernet в сетях рабочих групп
      • Fast Ethernet в магистралях зданий и кампусов
    • Обзор оборудования, поддерживающего Fast Ethernet
      • Сетевые адаптеры компании 3Com Fast EtherLink
      • Сетевой адаптер Intel EtherExpress PRO/100
      • Концентраторы SuperStack II Hub 100 компании 3Com
      • Концентраторы BayStack 100Base-T Hub компании Bay Networks
      • Коммутаторы Fast Ethernet
      • Интерфейсы Fast Ethernet в маршрутизаторах
    • Пример построения сети по технологии Fast Ethernet
  2. Технология FDDI
    • История создания стандарта FDDI
    • Основы технологии FDDI
    • Типы узлов и правила их соединения в сеть
      • Одиночное и двойное присоединение к сети
      • Количество MAC-узлов у станции
      • Типы портов станций и концентраторов FDDI и правила их соединения
      • Соединение Dual Homing
      • Присоединение станции к "блуждающему" MAC-узлу
      • Подключение станций с помощью оптических обходных переключателей (Optical Bypass Switch)
    • Спецификация зависящего от среды физического подуровня PMD
      • Структура физического соединения
      • Требования к мощности оптических сигналов
      • Кабели и разъемы
      • Функция определения сигнала уровня PMD
    • Физический подуровень PHY
      • Коды 4B/5B и их прием с помощью эластичного буфера
      • Процедура установления физического соединения
      • Конфигурирование внутреннего пути
    • МАС-уровень
      • Функции МАС-уровня
      • Форматы кадра и токена
      • Операции МАС-уровня
      • Инициализация кольца
      • Управление доступом к кольцу
    • Управление в сетями FDDI с помощью спецификации SMT
      • Общая характеристика функций управления сетью по спецификации SMT
      • Функции управления кольцом RMT
      • Функции управления, основанные на передаче кадров
    • В каких случаях рекомендуется использовать технологию FDDI
    • Обзор оборудования, поддерживающего FDDI
      • Сетевые адаптеры FDDI
      • Концентраторы FDDI
      • Коммутаторы FDDI
    • Пример построения сети по технологии FDDI
  3. Технология 100VG-AnyLAN
    • Общая характеристика технологии 100VG-AnyLAN
    • Стек протоколов технологии 100VG-AnyLAN
    • Функции уровня MAC
    • Функции уровня PMI
    • Функции уровня PMD
    • Пример работы сети 100VG-AnyLAN при передаче кадров данных
    • Обзор оборудования, поддерживающего технологию 100VG-AnyLAN
      • Сетевые адаптеры 10/100VG PC LAN компании Hewlett-Packard
      • Концентратор 100VG Hub-15 компании Hewlett-Packard
      • Коммутаторы и маршрутизаторы, поддерживающие 100VG-AnyLAN
    • Пример корпоративной сети на технологии 100VG-AnyLAN
  4. Перспективы высокоскоростных технологий - переход на гигабитные скорости

Back Home E-mail

Copyright © CIT


Teleport Pro Messages

http://www.cit-forum.com/: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.ru/cit: This file was not retrieved by Teleport Pro, because it is addressed on a domain or path outside the boundaries set for its Starting Address.
http://www.hostel.cctpu.edu.ru/doc/LVS/contents.htm: This file was not retrieved by Teleport Pro, because the server reports that this file cannot be found.